Bug 134676 - internal compiler error
internal compiler error
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 134675 134812 134857 134892 134908 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-05 11:37 EDT by Harald Hoyer
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 17:38:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source (248.15 KB, application/octet-stream)
2004-10-05 11:38 EDT, Harald Hoyer
no flags Details

  None (edit)
Description Harald Hoyer 2004-10-05 11:37:22 EDT
$ rpm -qf /usr/libexec/gcc/i386-redhat-linux/3.4.2/cc1plus
gcc-c++-3.4.2-4

/usr/include/kde/ksycocaentry.h: In constructor
`KSycocaEntry::KSycocaEntry(QDataStream&, int)':
/usr/include/kde/ksycocaentry.h:66: internal compiler error:
Segmentation fault
Comment 1 Harald Hoyer 2004-10-05 11:38:24 EDT
Created attachment 104784 [details]
Preprocessed source
Comment 2 Benjamin Kosnik 2004-10-05 12:01:43 EDT
Compiles for me without error w/ FSF gcc-3.4.2, with and without -O2, -g. 

Also works on FC2 gcc-3.3.x compilers.

This does ICE mainline g++ however, with the same flags.

-benjamin
Comment 3 Jakub Jelinek 2004-10-05 12:36:45 EDT
Simplified testcase:
extern "C" long foo (int);

struct A
{
  int i;
};

struct B
{
  static void foo (A &);
  B (int x) : c (x) { foo (d); }
  int c;
  A d;
};
Comment 4 Jakub Jelinek 2004-10-05 12:47:11 EDT
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=17846
Comment 5 Jakub Jelinek 2004-10-05 12:57:08 EDT
*** Bug 134675 has been marked as a duplicate of this bug. ***
Comment 6 Richard Henderson 2004-10-05 17:38:19 EDT
Upstream PR created.  Looks like it might be fixed in cvs too.
Comment 7 Bill Nottingham 2004-10-06 13:10:17 EDT
*** Bug 134812 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Jelinek 2004-10-06 18:07:35 EDT
*** Bug 134857 has been marked as a duplicate of this bug. ***
Comment 9 Jakub Jelinek 2004-10-07 09:14:39 EDT
Should be fixed in gcc-3.4.2-5.
Comment 10 Neal Becker 2004-10-07 09:20:29 EDT
Is there any way to get gcc-3.4.2-5 other than waiting for it to show 
up in rawhide? 
Comment 11 Jakub Jelinek 2004-10-07 10:25:52 EDT
*** Bug 134892 has been marked as a duplicate of this bug. ***
Comment 12 Jakub Jelinek 2004-10-07 10:26:45 EDT
*** Bug 134908 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.