Bug 1348147 - Add python-cradox to overcloud image
Summary: Add python-cradox to overcloud image
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-puppet-elements
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Pradeep Kilambi
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks: 1342571
TreeView+ depends on / blocked
 
Reported: 2016-06-20 09:52 UTC by Yurii Prokulevych
Modified: 2016-08-11 11:32 UTC (History)
10 users (show)

Fixed In Version: rhosp-director-images-9.0-20160712.1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 11:32:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC
OpenStack gerrit 331231 None None None 2016-06-21 13:25:58 UTC
Red Hat Bugzilla 1359760 None None None Never

Internal Links: 1359760

Description Yurii Prokulevych 2016-06-20 09:52:03 UTC
Description of problem:
To run gnocchi with ceph backend new package python-cradox is required.
According to rhbz 1343144 it's already added to repos. But it's not present in the overcloud image causing gnocchi to fail at start.


Version-Release number of selected component (if applicable):
rhosp-director-images-9.0-20160616.1.el7ost.noarch
rhosp-director-images-ipa-9.0-20160616.1.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install overcloud:
    openstack overcloud deploy --templates \
    --control-scale 3 \
    --compute-scale 2 \
    --ceph-storage-scale 1 \
    -e gnocchi_ceph.yaml --libvirt-type qemu \
    --ntp-server clock.redhat.com

2. $ cat gnocchi_ceph.yaml 
parameter_defaults:
    GnocchiBackend: 'rbd'

Additional info:
----------------
Manually customizing image with next commands helped to have gnocchi up and running:

virt-customize -a /var/lib/libvirt/images/overcloud-full.qcow2 --selinux-relabel --run-command 'yum localinstall -y http://rhos-release.virt.bos.redhat.com/repos/rhos-release/rhos-release-latest.noarch.rpm'

virt-customize -a /var/lib/libvirt/images/overcloud-full.qcow2 --selinux-relabel --run-command 'rhos-release -P 9-director'

virt-customize -a /var/lib/libvirt/images/overcloud-full.qcow2 --selinux-relabel --run-command 'yum install -y python-cradox'

Regards,
Yurii

Comment 5 Marian Krcmarik 2016-07-12 11:11:11 UTC
Deployed 2016-07-11.1 puddle with: rhosp-director-images-9.0-20160711.1.el7ost.noarch and openstack-tripleo-puppet-elements-2.0.0-3.el7ost.noarch and python-cradox is not installed on overcloud controller nodes this gnocchi resource fail to start.

Comment 14 Yurii Prokulevych 2016-07-19 16:38:05 UTC
Verified with openstack-tripleo-heat-templates-2.0.0-15.el7ost.noarch

Overcloud deployed with command:
--------------------------------
openstack  overcloud deploy --libvirt-type qemu --ntp-server clock.redhat.com --templates --control-scale 3 --compute-scale 2 --ceph-storage-scale 1

Than updated Gnocchi to use ceph backend:
-----------------------------
openstack  overcloud deploy --libvirt-type qemu --ntp-server clock.redhat.com --templates --control-scale 3 --compute-scale 2 --ceph-storage-scale 1 -e gnocchi_ceph.yam

cat gnocchi_ceph.yaml
parameter_defaults:
    GnocchiBackend: 'rbd'

Gnocchi API's CRUD test succeeded.

Comment 16 errata-xmlrpc 2016-08-11 11:32:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.