Bug 1359760 - python-cradox not installed during upgrade
Summary: python-cradox not installed during upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Pradeep Kilambi
QA Contact: Omri Hochman
URL:
Whiteboard:
: 1351784 (view as bug list)
Depends On:
Blocks: 1351784
TreeView+ depends on / blocked
 
Reported: 2016-07-25 12:16 UTC by Yurii Prokulevych
Modified: 2016-08-11 11:36 UTC (History)
13 users (show)

Fixed In Version: openstack-tripleo-heat-templates-2.0.0-23.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 11:36:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC
OpenStack gerrit 347873 None None None 2016-07-27 14:34:06 UTC
Red Hat Bugzilla 1348147 None None None Never
Launchpad 1606953 None None None 2016-07-27 14:38:17 UTC

Internal Links: 1348147

Description Yurii Prokulevych 2016-07-25 12:16:04 UTC
Description of problem:
-----------------------
Upgrade from RHOS-8 -> RHOS9.

openstack  overcloud deploy --libvirt-type qemu \
    --ntp-server clock.redhat.com --templates \
    --control-scale 3 --compute-scale 1 \
    --ceph-storage-scale 1 -e storage-environment.yaml \
    -e /usr/share/openstack-tripleo-heat-templates/environments/major-upgrade-pacemaker-converge.yaml

cat storage-environment.yaml
parameter_defaults:
  CinderEnableIscsiBackend: false
  CinderEnableRbdBackend: true
  NovaEnableRbdBackend: false
  GlanceBackend: rbd
  GnocchiBackend: rbd

rpm -qa | grep cradox

yum info python-cradox

Loaded plugins: product-id, search-disabled-repos, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Available Packages
Name        : python-cradox
Arch        : x86_64
Version     : 1.1.8
Release     : 2.el7ost
Size        : 205 k
Repo        : rhelosp-9.0-puddle/x86_64
Summary     : Python libraries for the Ceph librados library with use cython instead of ctypes
URL         : https://github.com/sileht/pycradox
License     : LGPLv2
Description : Python libraries for the Ceph librados library with use cython instead of ctypes



Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-tripleo-heat-templates-2.0.0-16.el7ost.noarch
openstack-tripleo-heat-templates-liberty-2.0.0-16.el7ost.noarch
openstack-tripleo-heat-templates-kilo-2.0.0-16.el7ost.noarch

Actual results:
gnocchi* services failed to start.

Expected results:
python-cradox is installed during upgrade.

Additional info:
----------------
Virtual setup: 3controllers + 1compute + 1ceph

Comment 2 Jiri Stransky 2016-07-26 17:52:58 UTC
I tried to work around this by manually installing python-cradox before the converge step of the upgrade, and i saw a fully successful converge with no services stopped.

Is python-cradox a hard dependency of Gnocchi -- should this be fixed on RPM spec level? We already install gnocchi packages so it could get pulled in automatically after that.

If it's a soft dependency, we can install it during the upgrade explicitly.

Comment 4 Pradeep Kilambi 2016-07-27 14:34:07 UTC
patch submitted to mitaka upgrades so python-cradox is installed explicitly during upgrades

https://review.openstack.org/#/c/347873/

Comment 7 Omri Hochman 2016-07-28 19:35:48 UTC
the python-cradox package should be installed on the overcloud machines post-upgrade the bug is ON_QA, but atm the latest puddle do not contain: openstack-tripleo-heat-templates-2.0.0-23.el7ost 

should be re-test in next puddle.

Comment 8 Mike Orazi 2016-07-29 15:32:52 UTC
*** Bug 1351784 has been marked as a duplicate of this bug. ***

Comment 9 mlammon 2016-08-03 16:51:30 UTC
8.0 GA - > 9 Upgrade
I followed the latest upgrade guide and finished on 02 AUG 16
(http://etherpad.corp.redhat.com/ospd9-upgrade)

Initial deployment:
openstack overcloud deploy --templates --control-scale 3 --compute-scale 1   --neutron-network-type vxlan --neutron-tunnel-types vxlan  --ntp-server clock.redhat.com --timeout 90 -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-environment.yaml --ceph-storage-scale 1

Initial step in documentation was removed so I did not follow it. 
(# workaround for https://bugzilla.redhat.com/show_bug.cgi?id=1359760
run-on-overcloud 'sudo yum -y install python-cradox')

I did not see the reported issue and verified this pkg installed as well

Verify on controller node:
[root@overcloud-controller-0 heat-admin]# rpm -qa | grep cradox
python-cradox-1.1.8-2.el7ost.x86_64

[root@overcloud-controller-1 ~]# rpm -qa | grep cradox
python-cradox-1.1.8-2.el7ost.x86_64

[root@overcloud-controller-2 ~]# rpm -qa | grep cradox
python-cradox-1.1.8-2.el7ost.x86_64

Comment 11 errata-xmlrpc 2016-08-11 11:36:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.