Bug 134818 - long URLs break kickstart functionality
long URLs break kickstart functionality
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
unspecified
All Linux
high Severity high
: ---
: ---
Assigned To: Robin Norwood
Fanny Augustin
:
Depends On:
Blocks: rhn360sat
  Show dependency treegraph
 
Reported: 2004-10-06 10:57 EDT by Max Spevack
Modified: 2007-10-29 21:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 12:33:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Spevack 2004-10-06 10:57:00 EDT
Description of problem:
In a very exciting moment, it has been theorized that sufficiently
long hostnames, when combined with the length of the session URIs
created/accessed by anaconda during a kickstart, can create a URL of
greater length than anaconda can gracefully handle.

Version-Release number of selected component (if applicable):
3.6

How reproducible:
Always

Steps to Reproduce:
1.  Use a machine with a fairly long hostname, such as
test01.x86_64.rhndev.redhat.com
2.  Set up a few different kickstarts, including a rhel-3-as-i386-u3
and a rhel-3-desktop-x86_64-u3
3.  The desktop kickstart should break in anaconda with a "failure to
retrieve URL" message.
4.  However, if you then create an alias of x.rhndev.redhat.com, thus
shortening the hostname, the kickstart will work!

See mspevack for more details.

Actual results:


Expected results:


Additional info:
This bug was discovered during the testing of bug #131094
Comment 1 Bret McMillan 2004-10-08 19:11:56 EDT
bumping up priority
Comment 2 Robin Norwood 2004-10-13 13:59:20 EDT
Ok - fix is in CVS.  Test plan:

Test both RHN-hosted kickstarts (on satellite), and externally hosted
kickstarts (both on satellite and in qa).  The RHN-hosted kickstarts
should have the --url line changed transparently to be a 'tiny url'. 
Non-RHN hsoted kickstarts should not be affected.
Comment 3 Todd Warner 2004-10-21 12:20:53 EDT
QA push. {ON_DEV,QA_READY} --> ON_QA
Comment 4 Robin Norwood 2004-10-21 13:42:00 EDT
DOC notes:

We should document the fact that on satellite, we no longer use the
long URL with the hash info (a42bc4398d...) - we use a much shorter
URL with hostname/ty - this is because it was possible to hit the
internal anaconda limit for the length of this URL with
reasonable-but-long hostnames.
Comment 5 Fanny Augustin 2004-11-23 15:56:50 EST
Functionality looks good on QA.  Waiting to test docs.
Comment 6 Todd Warner 2005-03-22 12:33:44 EST
Mass move from PROD_READY to CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.