Bug 1348303 - HAProxy redis config is missing AUTH option
Summary: HAProxy redis config is missing AUTH option
Keywords:
Status: CLOSED DUPLICATE of bug 1371657
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ga
: 10.0 (Newton)
Assignee: Pradeep Kilambi
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-20 18:35 UTC by Marius Cornea
Modified: 2016-09-13 21:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 21:17:20 UTC


Attachments (Terms of Use)

Description Marius Cornea 2016-06-20 18:35:55 UTC
Description of problem:
HAProxy redis config is missing AUTH option.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-5.0.0-0.20160609160634.8027ae2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud
2. Check HAProxy config

Actual results:
[root@overcloud-controller-2 heat-admin]# grep -A13 redis /etc/haproxy/haproxy.cfg 
listen redis
  bind 10.0.0.10:6379 transparent
  balance first
  option tcp-check
  tcp-check send PING\r\n
  tcp-check expect string +PONG
  tcp-check send info\ replication\r\n
  tcp-check expect string role:master
  tcp-check send QUIT\r\n
  tcp-check expect string +OK
  server overcloud-controller-0 10.0.0.12:6379 check fall 5 inter 2000 rise 2
  server overcloud-controller-1 10.0.0.14:6379 check fall 5 inter 2000 rise 2
  server overcloud-controller-2 10.0.0.13:6379 check fall 5 inter 2000 rise 2

Expected results:
the config also contains a tcp-check connect directive and an AUTH option, e.g:
listen redis
  bind 10.0.0.10:6379 
  balance first
  option tcp-check
  tcp-check connect
  tcp-check send AUTH\ examplepassword\r\n
  tcp-check send PING\r\n
  tcp-check expect string +PONG
  tcp-check send info\ replication\r\n
  tcp-check expect string role:master
  tcp-check send QUIT\r\n
  tcp-check expect string +OK
  server overcloud-controller-0 10.0.0.12:6379 check fall 5 inter 2000 rise 2
  server overcloud-controller-1 10.0.0.14:6379 check fall 5 inter 2000 rise 2
  server overcloud-controller-2 10.0.0.13:6379 check fall 5 inter 2000 rise 2

Additional info:

Comment 2 Pradeep Kilambi 2016-09-13 21:17:20 UTC

*** This bug has been marked as a duplicate of bug 1371657 ***


Note You need to log in before you can comment on or make changes to this bug.