Bug 1371657 - haproxy config missing auth statement for redis in ha setup
Summary: haproxy config missing auth statement for redis in ha setup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Pradeep Kilambi
QA Contact: Ofer Blaut
URL:
Whiteboard:
: 1348303 1374326 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-30 18:01 UTC by Alex Krzos
Modified: 2016-12-14 15:54 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160929150845.4cdc4fc.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:54:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 357344 None None None 2016-08-31 12:37:22 UTC

Description Alex Krzos 2016-08-30 18:01:39 UTC
Description of problem:
Deployed an OSP10 cloud via OSPd10 for testing gnocchi, I found gnocchi unable to connect to redis.  Comparison of the haproxy configuration between another OSP9 cloud and this OSP10 cloud showed that an auth statement is missing in the haproxy configuration for redis.

I added the statement into my three controllers and restart haproxy and was able to connect to redis through haproxy rather than directly to the redis server(s).

The config is missing:
tcp-check send AUTH\ (redis password)\r\n


Version-Release number of selected component (if applicable):
2016-08-29.1

How reproducible:


Steps to Reproduce:
1. Install/setup OSPd10
2. Install/Setup OSP10 overcloud
3. View /etc/haproxy/haproxy.cfg for missing tcp-check send AUTH statement

Actual results:


Expected results:


Additional info:
This prevents gnocchi from starting its storage aggregation worker.

Comment 3 Pradeep Kilambi 2016-09-08 13:03:37 UTC
*** Bug 1374326 has been marked as a duplicate of this bug. ***

Comment 4 Pradeep Kilambi 2016-09-13 21:17:20 UTC
*** Bug 1348303 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2016-12-14 15:54:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.