Bug 1348372 - Add multipathd RBD path checker
Summary: Add multipathd RBD path checker
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: ceph-qe-bugs
Steven J. Levine
URL:
Whiteboard:
Depends On:
Blocks: 1298558 1379890
TreeView+ depends on / blocked
 
Reported: 2016-06-21 02:05 UTC by Mike Christie
Modified: 2017-05-22 08:29 UTC (History)
14 users (show)

Fixed In Version: device-mapper-multipath-0.4.9-98.el7
Doc Type: Enhancement
Doc Text:
Multipath now includes support for Ceph RADOS block devices. RDB devices need special `uid` handling and their own checker function with the ability to repair devices. With this release, it is now possible to run multipath on top of RADOS block devices. Note, however, that the multipath RBD support should be used only when an RBD image with the `exclusive-lock` feature enabled is being shared between multiple clients.
Clone Of:
Environment:
Last Closed: 2016-11-04 08:19:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2536 normal SHIPPED_LIVE device-mapper-multipath bug fix and enhancement update 2016-11-03 14:18:10 UTC

Description Mike Christie 2016-06-21 02:05:52 UTC
Description of problem:

This is a request to merge the Ceph RBD multipathd path checker.

This is required by the ceph iSCSI HA project to support unclean failovers.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Mike Christie 2016-07-06 16:29:55 UTC
Just making a note about the patches needed for this bz:

Upstream commit:

commit b4d9ca8dc8bbfbd3782bf4cf2cb1a440685ccd07
Author: Hannes Reinecke <hare@suse.de>
Date:   Wed Nov 11 13:38:57 2015 +0100

    libmultipath: correctly initialize pp->sg_id

    The default SCSI protocol is 'SCSI_PROTOCOL_UNSPEC';
    '0' is SCSI_PROTOCOL_FCP.

    Signed-off-by: Hannes Reinecke <hare@suse.de>


and the final version of these patches:

https://www.redhat.com/archives/dm-devel/2016-July/msg00070.html
https://www.redhat.com/archives/dm-devel/2016-July/msg00071.html
https://www.redhat.com/archives/dm-devel/2016-July/msg00072.html
https://www.redhat.com/archives/dm-devel/2016-July/msg00073.html

Comment 11 Mike Christie 2016-10-18 20:02:59 UTC
Hey Steve,

Can we change the doc info so it does not sound like this is for general RBD use.

---
The multipath RBD support should only be used when you are sharing a RBD image, that has the exclusive-lock feature enabled, between multiple clients.
---

Basically, you cannot do fancy things people normally expect for multipath support like failover across network paths or round robin over multiple network paths. The support just handles failures on paths that are blacklisted due to another client taking the RBD exclusive-lock.

Comment 12 Steven J. Levine 2016-10-18 20:15:40 UTC
Mike:  I added your additional comment (just slightly edited) but I wasn't sure whether I need to go into detail on what this feature does not support.

Comment 13 Mike Christie 2016-10-18 20:33:24 UTC
Steve, what you have in comment #12 should be good.

Comment 15 errata-xmlrpc 2016-11-04 08:19:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2536.html


Note You need to log in before you can comment on or make changes to this bug.