Bug 134842 - Suggestion not to run prelink, updatedb when laptop is battery powered
Suggestion not to run prelink, updatedb when laptop is battery powered
Status: CLOSED DUPLICATE of bug 125779
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brock Organ
: FutureFeature
: 134843 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 13:55 EDT by bednar
Modified: 2011-07-26 21:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bednar 2004-10-06 13:55:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040612 Firefox/0.8

Description of problem:
I have an idea,

when laptop is battery powered the cron daily tasks should be started
after user confirmation. User should have choice not to run this power
consiming processes unless his laptop is plugged to AC outlet.
I imagine such requester:

Your machine is battery powered now. Do you allow to run cron daily
power consuming tasks (prelink, slocatedb, rpmdb) now?

Yes: Run it now!       No: run it later    No: run it when AC powered


Version-Release number of selected component (if applicable):
any

How reproducible:
Didn't try

Steps to Reproduce:
1.:)
2.
3.
    

Actual Results:  prelink eat about 20% of my battery

Expected Results:  opposite to actual

Additional info:
Comment 1 Jakub Jelinek 2004-10-06 14:39:22 EDT
Well, that is a request for laptop aware anacron and/or cron, I don't
see this as something prelink or updatedb or other cron tasks
should be handling.
Well, it cron/anacron has some flag how to say this job takes a long
time, that could be set, sure.

BTW, prelink in rawhide should eat less CPU and be faster, in -q mode.
Comment 2 Jakub Jelinek 2004-10-06 14:49:42 EDT
*** Bug 134843 has been marked as a duplicate of this bug. ***
Comment 3 Jason Vas Dias 2004-10-06 14:55:38 EDT

*** This bug has been marked as a duplicate of 125779 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:06:11 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.
Comment 5 Jonas Thiem 2011-07-26 21:54:45 EDT
Is it possible to reopen this? It links to a duplicate-marked bug which links to another duplicate which is #190268 which doesn't appear to be clearly related, and also is resolved while this issue appears to be clearly not: I'm on F15 and it happily runs prelink right now although I'm just on battery which is quite odd.

Or is this feature actually supposed to be already implemented and working and is it just bugging for me now?

Note You need to log in before you can comment on or make changes to this bug.