Bug 1348534 - Monitor mapping of swapped display / monitor does not work
Summary: Monitor mapping of swapped display / monitor does not work
Keywords:
Status: CLOSED DUPLICATE of bug 1362202
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.8
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Virt Viewer Maint
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-21 12:06 UTC by Radek Duda
Modified: 2016-08-11 09:34 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 09:34:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
spice-debug.log (76.40 KB, text/plain)
2016-06-21 12:06 UTC, Radek Duda
no flags Details
journal (vdagent -d) (3.12 KB, text/plain)
2016-06-21 12:08 UTC, Radek Duda
no flags Details

Description Radek Duda 2016-06-21 12:06:23 UTC
Created attachment 1170229 [details]
spice-debug.log

Description of problem:
If is the monitor mapping set like this:
monitor-mapping=1:2;2:1
or
monitor-mapping=2:1;1:2,
both displays are shown on the same monitor


Version-Release number of selected component (if applicable):
client: rhel 6.8-z
virt-viewer-2.0-14.el6.x86_64
guest: rhel 7.2-z
spice-vdagent-0.14.0-10.el7.x86_64


How reproducible:always


Steps to Reproduce:
1. Boot guest VM either in rhev-m or libvirt, and note VM's UUID (or GUID)
2. edit ~/.config/virt-viewer/setting:
[$UUID]
monitor-mapping=1:2;2:1
3.connect to VM:
$ remote-viewer -f spice://$IP_VM:$PORT_VM

Actual results:
Both VM displays are displayed on the same monitor


Expected results:
Two VM displays are displayed on two different monitors. VM displays are swapped:
Display1 -> Monitor2
Display2 -> Monitor1


Additional info: tested also for rhel7.3 client and it seems ok

Comment 1 Radek Duda 2016-06-21 12:08:27 UTC
Created attachment 1170230 [details]
journal (vdagent -d)

Comment 3 Jonathon Jongsma 2016-08-10 17:06:03 UTC
I cannot reproduce this here. It works exactly as expected every time I try.

I've tried the following environments:

virt-viewer-2.0-14.el6.x86_64 on RHEL 6.8
virt-viewer-4.0-1.fc24 on Fedora 24
virt-viewer from git master on Fedora 24
mingw-virt-viewer-2.0-7.el7ev on windows 7
mingw-virt-viewer-2.0-11.el7ev on windows 7

Every one of them works. Are you sure that it is always reproducible?

Comment 4 Radek Duda 2016-08-11 09:34:24 UTC
It is most probably a duplicate of a bug 1362202. I can reproduce it only with two monitors of different resolution, while the resolution of primary monitor is lower (see https://bugzilla.redhat.com/show_bug.cgi?id=1362202#c4). Moreover for rhel 7.2 guest I can reproduce it only with this configuration and monitor mapping 1:2;2:1. 

Tested on virt-viewer-2.0-14.el6.x86_64 on RHEL 6.8

*** This bug has been marked as a duplicate of bug 1362202 ***


Note You need to log in before you can comment on or make changes to this bug.