Bug 1362202 - Wrong position of remote-viewer windows in fullscreen mode with 2 real monitors - rhel 6.8 client
Summary: Wrong position of remote-viewer windows in fullscreen mode with 2 real monito...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.8
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Default Assignee for SPICE Bugs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1348534 (view as bug list)
Depends On: 1322356
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-01 14:00 UTC by Radek Duda
Modified: 2017-12-06 10:38 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1322356
Environment:
Last Closed: 2017-12-06 10:38:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
wrong-positioning (8.25 KB, text/plain)
2016-08-01 14:01 UTC, Radek Duda
no flags Details

Comment 1 Radek Duda 2016-08-01 14:01:41 UTC
Created attachment 1186439 [details]
wrong-positioning

Comment 3 Jonathon Jongsma 2016-08-03 20:03:26 UTC
Andrei Stepanov tried to reproduce this on a 6.9 client and was unable to reproduce. Radek, do you know of any way to reliably reproduce this?

Comment 4 Radek Duda 2016-08-04 09:32:28 UTC
Yes. Did little more research. It is reproducible on client configuration with monitors of different resolution, while the resolution of primary monitor has to be lower.

   primary       secondary
  +-------+  +---------------+
  |       |  |               |
  |       |  |               |
  |       |  |               |
  +-------+  |               |
  1280x1024  +---------------+
                1920x1080

two VM displays are then attached on the secondary monitor and retain the resolution of primary monitor:

  primary  full HD (secondary)
 +-------+  +---------------+
 |       |  |***|Guest  |***|
 |       |  |***|display|***|
 |       |  |***|       |***|
 +-------+  |***+-------+***|
1280x1024   +---------------+
               1920x1080
reproduced also on monitor configuration: primary: 1680x1050, secondary 1920x1080.
Reproducible only on Win7 guest (100%) and WinXP(60%). 
I tried both rhel 6.8-z  and rhel 7.3 nightly clients. The bug can be reproduced on both of them (even by Andrei).

Comment 5 Radek Duda 2016-08-11 09:34:24 UTC
*** Bug 1348534 has been marked as a duplicate of this bug. ***

Comment 6 Radek Duda 2016-08-11 09:39:08 UTC
reproducible also on rhel 7.2 and rhel 7.3 guests with monitor-mapping=1:2;2:1. Reproducibility 100%

Comment 7 Jonathon Jongsma 2016-09-08 21:29:23 UTC
I still cannot reproduce here.

Comment 9 Radek Duda 2016-09-09 09:59:43 UTC
So I tried to reproduce the bug again on up to date config.
a) rhel 7.3 nightly client:

virt-viewer-2.0-11.el7.x86_64
spice-glib-0.31-5.el7.x86_64
spice-gtk-0.31-5.el7.x86_64
spice-server-0.12.4-18.el7.x86_64
libvirt-2.0.0-8.el7.x86_64
kernel-3.10.0-505.el7.x86_64

it is reproducible ONLY with monitor-mapping=1:2;2:1 and with the resolution of primary monitor lower, then that of secondary monitor. I tried rhel7.2, rhel7.3 and rhel6.8 guests - 100% reproducible on given conditions on all of them. Also tried Win7 guest with ~50% reproducibility.

b) rhel 6.8-z client:

spice-gtk-0.26-7
spice-glib-0.26-7
virt-viewer-2.0-14

it is reproducible ONLY with monitor-mapping=1:2;2:1 and with the resolution of primary monitor lower, then that of secondary monitor. I tried rhel7.2, rhel7.3 and rhel6.8 guests - 100% reproducible on given conditions on all of them. Also tried Win7 guest, where it is not reproducible any more.

guests were established vie rhav-m portal (Red Hat Virtualization Manager Version: 4.0.4.1-0.1.el7ev), but it is reproducible on libvirt guests as well (tested rhel7.3)

Comment 10 Pavel Grunt 2016-10-12 07:00:45 UTC
Hi Radek,
(In reply to Radek Duda from comment #9)
> 
> b) rhel 6.8-z client:
> 
> spice-gtk-0.26-7
> spice-glib-0.26-7
> virt-viewer-2.0-14
> 
> it is reproducible ONLY with monitor-mapping=1:2;2:1 and with the resolution
> of primary monitor lower, then that of secondary monitor. I tried rhel7.2,
> rhel7.3 and rhel6.8 guests - 100% reproducible on given conditions on all of
> them. Also tried Win7 guest, where it is not reproducible any more.
> 
> guests were established vie rhav-m portal (Red Hat Virtualization Manager
> Version: 4.0.4.1-0.1.el7ev), but it is reproducible on libvirt guests as
> well (tested rhel7.3)

considering a strong correlation between this bug and the monitor mapping, can you please retest again with the latest virt-viewer:
virt-viewer-2.0-16.el6

It contains fixes for monitor mapping bugs:
https://bugzilla.redhat.com/show_bug.cgi?id=1351881
https://bugzilla.redhat.com/show_bug.cgi?id=1315206

Thanks

Comment 11 Radek Duda 2016-10-12 09:03:46 UTC
Hi Pavel,
I tested the bug reproducibility again with old and with new virt-viewer. New virt-viewer-2.0-16.el6 unfortunately does not solve this bug. Both guest displays are attached to the same monitor if I use monitor-mapping=1:2;2:1 - as stated in bug description.

Client packages:
spice-gtk-0.26-7
spice-glib-0.26-7
virt-viewer-2.0-16

Tested on rhel7.2, rhel 7.3 and rhel 6.8 guests with the same outcome.

Comment 16 Pavel Grunt 2016-10-14 13:35:34 UTC
I am not sure, client seems to behave fine:

requests correct stuff
(remote-viewer:6687): GSpice-DEBUG: channel-main.c:1077 main-1:0: monitor config: #0 1920x1080+1680+0 @ 32 bpp
(remote-viewer:6687): GSpice-DEBUG: channel-main.c:1077 main-1:0: monitor config: #1 1680x1050+0+0 @ 32 bpp

receives what requested:
(remote-viewer:6687): GSpice-DEBUG: channel-display.c:1732 display-2:0: monitor id: 0, surface id: 0, +1680+0-1920x1080
(remote-viewer:6687): GSpice-DEBUG: channel-display.c:1732 display-2:0: monitor id: 1, surface id: 0, +0+0-1680x1050

to me it looks like something in the desktop environment is messing with window placement

Comment 17 Jan Kurik 2017-12-06 10:38:31 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.