Bug 134864 - gnome-bluetooth-manager doesn't start on 64b platforms
Summary: gnome-bluetooth-manager doesn't start on 64b platforms
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
: 136994 (view as bug list)
Depends On:
Blocks: 131589
TreeView+ depends on / blocked
 
Reported: 2004-10-06 20:23 UTC by Zack Cerza
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: gnome-bluetooth-0.5.1-5.FC3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 16:08:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zack Cerza 2004-10-06 20:23:25 UTC
% gnome-bluetooth-manager 
/usr/bin/python: can't open file
'/usr/lib/python2.3/site-packages/gnomebt/manager.py'
% ls /usr/lib*/python2.3/site-packages/gnomebt/manager.py
/usr/lib64/python2.3/site-packages/gnomebt/manager.py

gnome-bluetooth-manager puts its python stuff in /usr/lib64 but
hardcodes /usr/lib/ in the source.

'/lib/' occurs on 142 lines in the upstream source, and a few times in
our patches. Ouch. Can the python stuff be moved to /usr/lib/ ?

Comment 1 Harald Hoyer 2004-10-25 09:37:56 UTC
*** Bug 136994 has been marked as a duplicate of this bug. ***

Comment 2 Dan Williams 2004-11-01 04:21:47 UTC
Zack, can you test with current gnome-bluetooth-0.5.1-5 in FC-3?  A
patch for this issue got put in on Oct 8th...  Is it still a problem?

Comment 3 Zack Cerza 2004-11-01 16:40:22 UTC
Yeah, it's still a problem.

In /usr/bin/gnome-bluetooth-manager:
exec /usr/bin/python /usr/lib/python2.3/site-packages/gnomebt/manager.py

$ rpm -ql gnome-bluetooth | grep manager.py
/usr/lib64/python2.3/site-packages/gnomebt/manager.py

$ rpm -q gnome-bluetooth
gnome-bluetooth-0.5.1-5.x86_64

I don't see the fix in the spec file or upstream changelog...

Comment 4 Zack Cerza 2004-12-06 22:42:29 UTC
Uh, ping?

Comment 5 Harald Hoyer 2004-12-07 11:24:16 UTC
yes, yes :) I am on it :) RHEL4 is fixed, FC3 update version prepared
yesterday.


Note You need to log in before you can comment on or make changes to this bug.