Bug 134877 - up2date GUI shows "0 kB" in size column
up2date GUI shows "0 kB" in size column
Status: CLOSED DUPLICATE of bug 107048
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
:
: 139222 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 17:29 EDT by Andrew
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 09:53:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Available Package Updates screen (50.11 KB, image/png)
2004-10-06 17:31 EDT, Andrew
no flags Details

  None (edit)
Description Andrew 2004-10-06 17:29:44 EDT
Description of problem:
up2date reports 0 kB as the size of most packages

Version-Release number of selected component (if applicable):
up2date-gnome-4.3.40-1
up2date-4.3.40-1
rhnlib-1.8-6.p23.fc3
rhn-applet-2.1.11-1


How reproducible:
Every time.

Steps to Reproduce:
1. Right click on Red Hat Alert Network Icon and select Launch up2date
2. Select defaults until you reach Available Package Updates screen
3.
  
Actual results:
See screenshot

Expected results:
Actual package sizes

Additional info:
When up2date does the "testing package set", it is possible to get an
error that indicates that it needs additional space on the filesystem,
even though the package sizes are listed as "0 kB".  Also, the "Total
size of selected packages to download" is also incorrect on this screen.
Calculating the actual space to be used would be very
processor-intensive (probably requiring several RPM transactions as is
done before installation, and to generate the error I described
above), but should this not be estimated based on the size of the
files, if not the actual information within the RPMs?  Thoughts anyone?
Comment 1 Andrew 2004-10-06 17:31:15 EDT
Created attachment 104871 [details]
Available Package Updates screen
Comment 2 Rahul Sundaram 2005-06-27 12:25:04 EDT
*** Bug 139222 has been marked as a duplicate of this bug. ***
Comment 3 John Thacker 2006-10-29 09:53:16 EST

*** This bug has been marked as a duplicate of 107048 ***

Note You need to log in before you can comment on or make changes to this bug.