Bug 134880 - Typo in Xclients causes X sessions to crash
Summary: Typo in Xclients causes X sessions to crash
Status: CLOSED DUPLICATE of bug 134673
Alias: None
Product: Fedora
Classification: Fedora
Component: xinitrc   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-06 23:06 UTC by Orion Poplawski
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:06:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Orion Poplawski 2004-10-06 23:06:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
Upgraded FC3test2 to latest devel and X logins fail.  Problem is typo
in /etc/X11/xinit/Xclients script:

# check to see if the user has a preferred desktop
PREFERRED=
if [ -f /etc/sysconfig/desktop ]; then
    . /etc/sysconfig/desktop
    if [ "$DESKTOP" = "GNOME" ]; then
        PREFERRED=gnome-session
    elif [ "$DESKTOP" = "KDE" ]; then
        PREFERRED=startkde
fi

It's missing a "fi" after PREFERRED=startkde


Version-Release number of selected component (if applicable):
xinitrc-4.0.7-1

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to xinitrc-4.0.7-1
2.
3.
    

Additional info:

Comment 1 Mike A. Harris 2004-10-07 00:30:39 UTC

*** This bug has been marked as a duplicate of 134673 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:06:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.