Bug 1348944 - Change the glusterd log file name to glusterd.log
Summary: Change the glusterd log file name to glusterd.log
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vijay Bellur
QA Contact:
URL:
Whiteboard:
Depends On: 1306120
Blocks: 1352772
TreeView+ depends on / blocked
 
Reported: 2016-06-22 11:18 UTC by Atin Mukherjee
Modified: 2017-03-27 18:14 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: Enhancement
Doc Text:
Clone Of: 1306120
: 1352772 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:14:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2016-06-22 11:18:16 UTC
+++ This bug was initially created as a clone of Bug #1306120 +++

Description of problem:
I am not aware of logic behind the glusterd log file name which is           "etc-glusterfs-glusterd.vol.log' at present.

Comment 1 Vijay Bellur 2016-07-04 07:11:39 UTC
REVIEW: http://review.gluster.org/13426 (logging: Change log file name for glusterd) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Vijay Bellur 2016-07-04 13:16:22 UTC
REVIEW: http://review.gluster.org/13426 (logging: Change log file name for glusterd) posted (#4) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Vijay Bellur 2016-07-05 03:54:23 UTC
COMMIT: http://review.gluster.org/13426 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 8d41243f18c4a9c89028c8fc5e54b7e2b5e4309d
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Wed Feb 10 18:27:38 2016 -0500

    logging: Change log file name for glusterd
    
    log file names are based on:
    
     a. user provided input (through -l switch while starting a gluster process)
     b. mount point paths in the case of native clients
     c. volume/configuration files used for starting a gluster process
     d. volume server used for starting a gluster process
    
    Currently glusterd uses scheme c. to have a log file name that reads as
    
    INSTALL_PREFIX-etc-glusterfs-glusterd.log
    
    Since glusterd has a well known configuration file, it does not make much
    sense to have log file name based on scheme c. This patch changes the name of
    glusterd's log file to "glusterd.log". Hopefully this enables users to identify
    glusterd's log file more easily.
    
    Change-Id: I2d04179c4b9b06271b50eeee3909ee259e8cf547
    BUG: 1348944
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/13426
    Tested-by: Atin Mukherjee <amukherj@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 4 Shyamsundar 2017-03-27 18:14:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.