Bug 1352772 - Change the glusterd log file name to glusterd.log
Summary: Change the glusterd log file name to glusterd.log
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On: 1306120 1348944
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-05 03:55 UTC by Atin Mukherjee
Modified: 2016-07-05 15:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1348944
Environment:
Last Closed: 2016-07-05 15:40:13 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2016-07-05 03:55:34 UTC
+++ This bug was initially created as a clone of Bug #1348944 +++

+++ This bug was initially created as a clone of Bug #1306120 +++

Description of problem:
I am not aware of logic behind the glusterd log file name which is           "etc-glusterfs-glusterd.vol.log' at present.

--- Additional comment from Vijay Bellur on 2016-07-04 03:11:39 EDT ---

REVIEW: http://review.gluster.org/13426 (logging: Change log file name for glusterd) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-07-04 09:16:22 EDT ---

REVIEW: http://review.gluster.org/13426 (logging: Change log file name for glusterd) posted (#4) for review on master by Atin Mukherjee (amukherj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-07-04 23:54:23 EDT ---

COMMIT: http://review.gluster.org/13426 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 8d41243f18c4a9c89028c8fc5e54b7e2b5e4309d
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Wed Feb 10 18:27:38 2016 -0500

    logging: Change log file name for glusterd
    
    log file names are based on:
    
     a. user provided input (through -l switch while starting a gluster process)
     b. mount point paths in the case of native clients
     c. volume/configuration files used for starting a gluster process
     d. volume server used for starting a gluster process
    
    Currently glusterd uses scheme c. to have a log file name that reads as
    
    INSTALL_PREFIX-etc-glusterfs-glusterd.log
    
    Since glusterd has a well known configuration file, it does not make much
    sense to have log file name based on scheme c. This patch changes the name of
    glusterd's log file to "glusterd.log". Hopefully this enables users to identify
    glusterd's log file more easily.
    
    Change-Id: I2d04179c4b9b06271b50eeee3909ee259e8cf547
    BUG: 1348944
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/13426
    Tested-by: Atin Mukherjee <amukherj@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 1 Vijay Bellur 2016-07-05 03:58:47 UTC
REVIEW: http://review.gluster.org/14857 (logging: Change log file name for glusterd) posted (#2) for review on release-3.8 by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Atin Mukherjee 2016-07-05 15:40:13 UTC
Since this impacts the users visibility w.r.t change in a log file name and 3.8 is been already out, we will take this as part of 3.9.


Note You need to log in before you can comment on or make changes to this bug.