Bug 1349041 - DE Theme Foreground text colour settings ignored for tooltips
Summary: DE Theme Foreground text colour settings ignored for tooltips
Keywords:
Status: CLOSED DUPLICATE of bug 1348963
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-22 14:59 UTC by Mike Simms
Modified: 2016-06-23 09:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-23 09:58:43 UTC
Type: Bug


Attachments (Terms of Use)
screenshot showing illegible popup (194.74 KB, image/png)
2016-06-22 14:59 UTC, Mike Simms
no flags Details
Cinammon screenshot (87.85 KB, image/jpeg)
2016-06-22 17:42 UTC, Mike Simms
no flags Details

Description Mike Simms 2016-06-22 14:59:53 UTC
Created attachment 1170823 [details]
screenshot showing illegible popup

Description of problem: I use MATE spin with Blue-Submarine theme. The tooltips that popup to describe forum topics or pictures on webpages are illegible because the black foreground text colour is ignored and white used instead. The same issue affects Blue Menta, the default MATE theme and all other themes with light background popups.


Version-Release number of selected component (if applicable): firefox-47.0-4.fc24


How reproducible: all the time.


Steps to Reproduce:
1.Set Blue-Submarine or Blue Menta as the GUI theme in MATE
2. Open Firefox and navigate to http://forums.fedoraforum.org/search.php?do=getnew
3. Hover over a topic title

Actual results: Illegible low contrast tooltips.


Expected results: Black text that can be read


Additional info:f24 mate-compiz x86_64 (1.14.0-1)
mate-themes 3.20.8-3
firefox 47.0-4

Comment 1 Wolfgang Ulbrich 2016-06-22 17:24:24 UTC
Dear firefox maintainer.
FF-47 still ignore fg color setting in  themes for  GTK+-3.20 and use always a white color.
For this reason you don't see the issue in themes which use a white fg color on a dark bg for tooltips, like BlackMate or Adwaita.
With ff-46 all was fine in our themes.
Eg. BlueMenta

tooltip,
.tooltip {
	border-radius: 2px;
	border-width: 1px;
	border-color: @theme_tooltip_fg_color;
	border-style: solid;
}

tooltip.background,
.tooltip.background {
	background-color: @theme_tooltip_bg_color;
    background-clip: padding-box;
}

tooltip label,
.tooltip label {
	text-shadow: none;
	color: @theme_tooltip_fg_color;
	padding: 8px;
}

tooltip decoration,
.tooltip decoration,
tooltip.csd decoration,
.tooltip.csd decoration,
tooltip.ssd decoration,
.tooltip.ssd decoration,
tooltip.solid-csd decoration,
.tooltip.solid-csd decoration,
tooltip.background.csd decoration,
.tooltip.background.csd decoration,
tooltip.background.ssd decoration,
.tooltip.background.ssd decoration,
tooltip.background.solid-csd decoration,
.tooltip.background.solid-csd decoration {
	background-color: transparent;
}

Note, adding style classes back for gtk+-3.20 , here we use nodes, was needed to get tooltips working with ff-46.

I have no ideas anymore to fix that from theme side, and i'm sure my settings are valid after spending about 1000 hours to get our themes working with gtk+-3.20 ;)

So please fix firefox or tell me how to select the fg color.

Comment 2 Mike Simms 2016-06-22 17:42:14 UTC
Created attachment 1170980 [details]
Cinammon screenshot

Hi, this has been added by smjester86 to a topic I created at fedoraforum.org. The issue affects Cinnamon as well

http://forums.fedoraforum.org/showthread.php?p=1764410&posted=1#post1764410

Comment 3 Martin Stransky 2016-06-23 09:58:43 UTC

*** This bug has been marked as a duplicate of bug 1348963 ***

Comment 4 Martin Stransky 2016-06-23 09:59:29 UTC
That's bug in Firefox, fixed packages are available.


Note You need to log in before you can comment on or make changes to this bug.