Bug 134916 - gpdf crashes on particular PDF file
gpdf crashes on particular PDF file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gpdf (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
: 135896 (view as bug list)
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-10-07 03:53 EDT by Christine Caulfield
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 16:52:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christine Caulfield 2004-10-07 03:53:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041002
Firefox/0.10.1

Description of problem:
When opening the PDF file at
http://www.pirastro.com/pricelist/p-list2004/cello.pdf

gpdf just crashes and goes into bug buddy

Version-Release number of selected component (if applicable):
gpdf-2.8.0-1

How reproducible:
Always

Steps to Reproduce:
1. Download http://www.pirastro.com/pricelist/p-list2004/cello.pdf
2. open it in gpdf
3. (or just browse to that URL and let it open gnome-pdf-viewer)
    

Actual Results:  gpdf crashed. bug buddy (unfortunately) didn't show
any useful information like a traceback.

Expected Results:  a display of the prices of 'cello strings.

Additional info:

I have saved a copy of this PDF file in case Pirastro update their web
site.
Comment 1 Marco Pesenti Gritti 2004-10-12 10:01:04 EDT
I guess this does not qualify as a YellowPad anymore since ggv is now
the default (and opens the file correctly).

I reported it upstream:

http://www.pirastro.com/pricelist/p-list2004/cello.pdf
Comment 2 Marco Pesenti Gritti 2004-10-12 16:52:06 EDT
Should be fixed in gpdf-2.8.0-2. Apparently the package did just need
to be rebuilt.
Comment 3 Marco Pesenti Gritti 2004-10-12 19:24:45 EDT
For the record, maintainer comment on what could have caused this:

"
Yeah, sorry.

GPdf uses private gnome-print headers...

And private stuff doesn't have ABI-guarantees...

The plan for 2.10 is to stop using that, of course.
"
Comment 4 Marco Pesenti Gritti 2004-11-06 09:41:03 EST
*** Bug 135896 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.