Bug 1349261 - Do not install all flavours of english langpacks
Summary: Do not install all flavours of english langpacks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-23 05:35 UTC by Vít Ondruch
Modified: 2016-06-27 18:25 UTC (History)
5 users (show)

Fixed In Version: libreoffice-5.1.4.2-3.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-27 18:25:18 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 850709 0 unspecified CLOSED Avoid installation of strange flavors of english 2021-02-22 00:41:40 UTC

Internal Links: 850709

Description Vít Ondruch 2016-06-23 05:35:26 UTC
Description of problem:
Installation of LibreOffice pulls in hunspell-en, which contains all flavours of english language I am not interested in (this means that the spell suggestion menu is all screen long). It should only install hunspell-en-US by default. It seems that this is due to commits like:

http://pkgs.fedoraproject.org/cgit/rpms/libreoffice.git/commit/?id=809384b54458b7499d5e19a7e3508938d6609ceb

and 

http://pkgs.fedoraproject.org/cgit/rpms/libreoffice.git/commit/?id=3d4ac175ca7a6cfbf2fc1046a00ab563bb0cd725




Version-Release number of selected component (if applicable):
$ rpm -q libreoffice-langpack-en 
libreoffice-langpack-en-5.2.0.0-7.beta1.fc25.x86_64


How reproducible:
Always


Steps to Reproduce:
1.
2.
3.

Actual results:
Strange english flavours are installed


Expected results:
Only US english dictionary is installed


Additional info:
Please note that this is regression considering http://pkgs.fedoraproject.org/cgit/rpms/libreoffice.git/commit/?id=007bc34d982d87bf27e51c4dbf61c30a5acece52

Comment 1 David Tardon 2016-06-23 06:57:55 UTC
The actual bug is that libreoffice-langpack-en requires hunspell-en.

Comment 2 Fedora Update System 2016-06-24 05:53:39 UTC
libreoffice-5.1.4.2-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-79961c949b

Comment 3 Fedora Update System 2016-06-25 00:31:34 UTC
libreoffice-5.1.4.2-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-79961c949b

Comment 4 Fedora Update System 2016-06-25 20:12:11 UTC
libreoffice-5.1.4.2-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2bf872a06

Comment 5 Fedora Update System 2016-06-26 19:26:25 UTC
libreoffice-5.1.4.2-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2bf872a06

Comment 6 Vít Ondruch 2016-06-27 12:47:35 UTC
Thank you for the fix. It works for me on Rawhide.

Comment 7 David Tardon 2016-06-27 14:23:23 UTC
Btw, it's quite funny to see a bug report which requests only American English dict. to be installed by default, but it is itself written in British English .-)

Comment 8 Vít Ondruch 2016-06-27 14:40:17 UTC
Well, that was reported to avoid such mistakes ;)

Comment 9 Fedora Update System 2016-06-27 18:24:59 UTC
libreoffice-5.1.4.2-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.