Bug 850709 - Avoid installation of strange flavors of english
Avoid installation of strange flavors of english
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hunspell-en (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 03:49 EDT by Vít Ondruch
Modified: 2016-06-23 01:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-28 04:35:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2012-08-22 03:49:56 EDT
Description of problem:
Could you please consider to either git rid of some strange English dialects, or better to split the main package into subpackages with dialects? It is really annoying that every time I'd like to use spell checking in my FF, I have to choose English from long list of dialects I'll never use. Moreover it is even more ridiculous to see that most of these dialects are in fact just links to en_GB or en_US.

This seems to be quite common annoyance [1, 2]

Version-Release number of selected component (if applicable):
hunspell-en-0.20110318-2.fc17.noarch

How reproducible:
Always

Steps to Reproduce:
1. FF text field
2. Context menu
3. Languages
  
Actual results:
Too many English flavors

Expected results:
Only English US, may be GB. But 



[1] http://forums.fedoraforum.org/showthread.php?t=212771
[2] https://support.mozilla.org/sk/questions/680799#answer-265125
Comment 1 Elad Alfassa 2012-08-22 06:07:09 EDT
I agree that having British English and American English only by default would be a much more sane option to improve user experience, provided that we can auto-install the related spellchecking packages when users changes their UI language to another dialect.

(Speaking as a designer, not a developer)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Elad Alfassa 2012-08-22 06:09:03 EDT
Another option might be merging all dialects into one entry, titled English, but I'm not sure if that's feasible.
Comment 3 Caolan McNamara 2012-08-27 11:41:31 EDT
How about I split out say, the hunspell-en-US and hunspell-en-GB ones so people can strip it down to the common varieties and leave an umbrella hunspell-en that contains the rest and requires those two
Comment 4 Vít Ondruch 2012-08-28 01:53:55 EDT
Hm, but this does not solve the original issue I am afraid :/ If I am not mistaken, then the dependencies are as follows:

xulrunner -> hunspell -> hunspell-en -> hunspell-en-US, hunspell-en-GB

So at the end, I still have every english flavor on my system. I tried to test my suspicion, but interestingly enough, you latest hunspell-en-0.20110318-7.fc19 build is not tagged for F19 and -6 keeps installing.
Comment 5 Caolan McNamara 2012-08-28 04:35:01 EDT
The chain is now "xulrunner -> hunspell -> hunspell-en-US" I tweaked hunspell at the same time but failed to build it into the right release.

http://kojipkgs.fedoraproject.org/packages/hunspell-en/0.20110318/8.fc19
http://kojipkgs.fedoraproject.org/packages/hunspell/1.3.2/8.fc19/

should "do the right thing" and hit rawhide today/tomorrow
Comment 6 Elad Alfassa 2012-08-28 05:40:39 EDT
can you please push that fix to the f18 branch as well?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Vít Ondruch 2012-08-28 08:25:36 EDT
(In reply to comment #5)
> should "do the right thing" and hit rawhide today/tomorrow

Trying using mock, it seems it pulls in the -en-US. Nice! Hope that there will be no other surprise in production system (something along lines "libreoffice requires hunspell-en")

Agree with Elad, would be nice to have it in F18 as well.

Thank you.
Comment 8 Fedora Update System 2012-08-29 06:11:40 EDT
hunspell-en-0.20110318-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/hunspell-en-0.20110318-8.fc18
Comment 9 Elad Alfassa 2012-08-30 09:16:39 EDT
Don't forget to submit the hunspell dependency change update to f18 too, please



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Fedora Update System 2012-09-03 06:23:58 EDT
hunspell-1.3.2-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/hunspell-1.3.2-8.fc18
Comment 11 Fedora Update System 2012-09-03 07:55:08 EDT
hunspell-en-0.20110318-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/hunspell-en-0.20110318-8.fc17
Comment 12 Fedora Update System 2012-09-07 03:50:43 EDT
libreoffice-3.6.1.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libreoffice-3.6.1.2-2.fc18
Comment 13 Fedora Update System 2012-09-11 06:54:48 EDT
hunspell-1.3.2-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/hunspell-1.3.2-8.fc17
Comment 14 Fedora Update System 2012-09-11 20:28:18 EDT
hunspell-en-0.20110318-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2012-09-12 03:59:44 EDT
libreoffice-3.5.6.2-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.6.2-4.fc17
Comment 16 Fedora Update System 2012-09-17 18:47:04 EDT
hunspell-1.3.2-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2012-09-17 18:49:33 EDT
libreoffice-3.6.1.2-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2012-09-17 19:31:20 EDT
hunspell-en-0.20110318-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2012-09-26 04:21:55 EDT
libreoffice-3.5.6.2-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.6.2-5.fc17
Comment 20 Fedora Update System 2012-09-27 00:21:45 EDT
hunspell-1.3.2-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.