Bug 134941 - gdm fails to reset console user if Xserver is killed with Ctrl-Alt-Backspace
Summary: gdm fails to reset console user if Xserver is killed with Ctrl-Alt-Backspace
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pam   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 86481 (view as bug list)
Depends On:
Blocks: FC3Blocker
TreeView+ depends on / blocked
 
Reported: 2004-10-07 13:32 UTC by Thomas Woerner
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 18:20:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Don't check existance of TTY when dropping console perms (2.81 KB, patch)
2004-10-20 09:24 UTC, Ray Strode [halfline]
no flags Details | Diff

Description Thomas Woerner 2004-10-07 13:32:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10

Description of problem:
gdm should set console user back to root if Xserver gets killed.

Version-Release number of selected component (if applicable):
gdm-2.6.0.5-2

How reproducible:
Always

Steps to Reproduce:
1. Go to runlevel 5
2. Log in as user1
3. Kill Xserver with Ctrl-Alt-Backspace
5. Login as an user2: Files from /etc/security/console.perms still
belong to user1


Actual Results:  No reset of file permissions.

Expected Results:  Reset of file permissions.

Additional info:
This also happens on RHEL3 etc.

Comment 1 Ray Strode [halfline] 2004-10-20 09:20:52 UTC
Hi so this actually looks like it may be a problem with pam_console.so and not
GDM.  Basically pam_console checks to make sure the display socket is around
before unref'n console priveleges.  Of course, if the user ctrl-alt-backspaces
then the display socket will be wiped.

Comment 2 Ray Strode [halfline] 2004-10-20 09:24:37 UTC
Created attachment 105500 [details]
Don't check existance of TTY when dropping console perms

Here's a patch that inhibits the checks when dropping console perms.  It needs
to be reviewed by someone who knows pam better than me.

Comment 3 Tomas Mraz 2004-10-20 12:16:08 UTC
I think the patch should be harmless however I'll modify it to skip
the check only on X logins not console logins.




Comment 4 Ray Strode [halfline] 2004-10-20 18:20:34 UTC
patch in rawhide seems to work fine, closing...

Comment 5 Ray Strode [halfline] 2004-11-05 03:03:36 UTC
*** Bug 86481 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.