Bug 86481 - After ctrl+alt-bs user exit, other users cannot use sound
After ctrl+alt-bs user exit, other users cannot use sound
Status: CLOSED DUPLICATE of bug 134941
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
: Triaged
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-03-23 17:13 EST by Paul Broadhead
Modified: 2007-04-18 12:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Broadhead 2003-03-23 17:13:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
If a user exits the gnome desktop using ctrl-alt-backspace (may be because an
application has locked), when another user tries to login, permissions on
devices are still held by the previous user.  In particular, the sound devices.
 If you have a mixer applet on your panel, you get an error dialogue box with
the message "Couldn't open mixer device /dev/sound/mixer".  Killing any hung
processes from the previous user does not help.  The only solution I have found
is to reboot.  Is there some /etc/init.d/ typer service I can restart to reset
the permissions?

Using Redhat 8.0, fully patched via redhat network.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.login to gnome desktop as user A
2.exit desktop using ctrl-alt-backspace
3.login to gnome desktop as user B
    

Actual Results:  user B, who has a mixer applet, gets "Couldn't open mixer
device /dev/sound/mixer" error and has no access to sound.

Expected Results:  user B should have access to sound as normal

Additional info:
Comment 1 Havoc Pennington 2003-07-30 16:58:40 EDT
Nalin, George - is the problem here consolehelper or gdm?
Comment 2 George Lebl 2003-07-30 17:29:43 EDT
Most likely gdm.  The problem is that there are many races and it's possible
that the pam_close_session was not called in that case.  This should be fixed in
the newest devel version, but not in the stable version.
Comment 3 George Lebl 2003-07-31 19:43:18 EDT
This should be now fixed in upstream gdm 2.4.1.5 (stable) which I released today.  
Comment 4 Alexander Larsson 2003-09-04 07:43:46 EDT
We've upgraded, so this is likely fixed in RAWHIDE. 
Does it work for you?
Comment 5 Paul Broadhead 2003-09-06 07:33:53 EDT
I've been using Redhat 9.0 for several months with gdm-2.4.1.3-5.1.  This
version does not behave in the same way; a simple ctrl+alt-bs user exit will not
leave the sound device (an others) in an unusable state.  However, if the user X
session crashes the same problems can still occur, sometimes. e.g. the
commercial demo version of Tux racers is particularly prone to causing the problem.

Can I use gdm 2.4.1.5 on RH 9?  If so I'll try and that and see what happens
with Tux racers....
Comment 6 Ray Strode [halfline] 2004-11-04 22:03:20 EST

*** This bug has been marked as a duplicate of 134941 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:52:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.