Bug 1349736 - [Wayland] firefox crash at xcb_send_request64() when launched from menu
Summary: [Wayland] firefox crash at xcb_send_request64() when launched from menu
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:e3efcc1342783e1105f62c47fb8...
Keywords: Reopened
: 1348344 1378634 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-24 06:48 UTC by Martin Stransky
Modified: 2016-11-05 09:36 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-06-29 09:11:44 UTC


Attachments (Terms of Use)
File: backtrace (33.82 KB, text/plain)
2016-06-24 06:48 UTC, Martin Stransky
no flags Details
File: cgroup (240 bytes, text/plain)
2016-06-24 06:48 UTC, Martin Stransky
no flags Details
File: core_backtrace (10.28 KB, text/plain)
2016-06-24 06:48 UTC, Martin Stransky
no flags Details
File: dso_list (14.27 KB, text/plain)
2016-06-24 06:48 UTC, Martin Stransky
no flags Details
File: environ (1.67 KB, text/plain)
2016-06-24 06:49 UTC, Martin Stransky
no flags Details
File: limits (1.29 KB, text/plain)
2016-06-24 06:49 UTC, Martin Stransky
no flags Details
File: maps (74.13 KB, text/plain)
2016-06-24 06:49 UTC, Martin Stransky
no flags Details
File: mountinfo (3.44 KB, text/plain)
2016-06-24 06:49 UTC, Martin Stransky
no flags Details
File: namespaces (102 bytes, text/plain)
2016-06-24 06:49 UTC, Martin Stransky
no flags Details
File: open_fds (3.60 KB, text/plain)
2016-06-24 06:49 UTC, Martin Stransky
no flags Details
File: proc_pid_status (1.08 KB, text/plain)
2016-06-24 06:49 UTC, Martin Stransky
no flags Details
File: var_log_messages (1.04 KB, text/plain)
2016-06-24 06:49 UTC, Martin Stransky
no flags Details

Description Martin Stransky 2016-06-24 06:48:46 UTC
Description of problem:
crash

Version-Release number of selected component:
firefox-47.0-6.wayland.fc25

Additional info:
reporter:       libreport-2.7.1
backtrace_rating: 4
cmdline:        /usr/lib64/firefox/firefox
crash_function: AsmJSFaultHandler(int, siginfo_t*, void*)
executable:     /usr/lib64/firefox/firefox
global_pid:     3266
kernel:         4.5.7-300.fc24.x86_64
pkg_vendor:     (none)
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            500

Truncated backtrace:
Thread no. 1 (1 frames)
 #2 AsmJSFaultHandler(int, siginfo_t*, void*) at /usr/src/debug/firefox-47.0/firefox-47.0/js/src/asmjs/WasmSignalHandlers.cpp:1157

This is a private, duplicate bug report of bug 1348344. The report has been created because Bugzilla cannot grant access to a comment for a specific group.

Comment 1 Martin Stransky 2016-06-24 06:48:52 UTC
Created attachment 1171822 [details]
File: backtrace

Comment 2 Martin Stransky 2016-06-24 06:48:54 UTC
Created attachment 1171823 [details]
File: cgroup

Comment 3 Martin Stransky 2016-06-24 06:48:56 UTC
Created attachment 1171824 [details]
File: core_backtrace

Comment 4 Martin Stransky 2016-06-24 06:48:59 UTC
Created attachment 1171825 [details]
File: dso_list

Comment 5 Martin Stransky 2016-06-24 06:49:01 UTC
Created attachment 1171826 [details]
File: environ

Comment 6 Martin Stransky 2016-06-24 06:49:03 UTC
Created attachment 1171827 [details]
File: limits

Comment 7 Martin Stransky 2016-06-24 06:49:06 UTC
Created attachment 1171828 [details]
File: maps

Comment 8 Martin Stransky 2016-06-24 06:49:08 UTC
Created attachment 1171829 [details]
File: mountinfo

Comment 9 Martin Stransky 2016-06-24 06:49:10 UTC
Created attachment 1171830 [details]
File: namespaces

Comment 10 Martin Stransky 2016-06-24 06:49:13 UTC
Created attachment 1171831 [details]
File: open_fds

Comment 11 Martin Stransky 2016-06-24 06:49:15 UTC
Created attachment 1171832 [details]
File: proc_pid_status

Comment 12 Martin Stransky 2016-06-24 06:49:17 UTC
Created attachment 1171833 [details]
File: var_log_messages

Comment 13 Martin Stransky 2016-06-24 06:49:19 UTC

*** This bug has been marked as a duplicate of bug 1348344 ***

Comment 14 Martin Stransky 2016-06-24 06:56:06 UTC
Reproduction steps:
- Download firefox from https://copr.fedorainfracloud.org/coprs/stransky/firefox-wayland/
- Launch from side menu bar
- crash (ABRT catches it)
- launches fine from terminal

Comment 15 Martin Stransky 2016-06-24 06:56:26 UTC
+ run Gnome session on Wayland

Comment 16 Martin Stransky 2016-06-28 10:14:30 UTC
*** Bug 1348344 has been marked as a duplicate of this bug. ***

Comment 17 Martin Stransky 2016-06-29 09:11:44 UTC
Fixed by disabling start-up notifications on -8.wayland package.

Comment 18 Roel van de Kraats 2016-08-01 09:27:34 UTC
Similar problem has been detected:

Browsed to maps.google.com (on Fedora 24 running in a VMware virtual machine). Note that the same excersize on a pre-upgraded Fedora 23 caused a VMware Workstation crash.

reporter:       libreport-2.7.2
backtrace_rating: 4
cmdline:        /usr/lib64/firefox/firefox
crash_function: AsmJSFaultHandler(int, siginfo_t*, void*)
executable:     /usr/lib64/firefox/firefox
global_pid:     58835
kernel:         4.6.4-301.fc24.x86_64
package:        firefox-47.0.1-2.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         firefox killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            578

Comment 19 M. Edward (Ed) Borasky 2016-09-23 00:11:47 UTC
*** Bug 1378634 has been marked as a duplicate of this bug. ***

Comment 20 M. Edward (Ed) Borasky 2016-09-23 00:19:27 UTC
See bug 1378617 ... abrt told me that was a duplicate of this one but I'm not running Wayland.


Note You need to log in before you can comment on or make changes to this bug.