Bug 1350478 - copying & pasting text within writer resets the paragraph style to "Default style"
Summary: copying & pasting text within writer resets the paragraph style to "Default s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1352388 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-27 14:40 UTC by Thorsten Leemhuis
Modified: 2016-07-06 01:27 UTC (History)
6 users (show)

Fixed In Version: libreoffice-5.1.4.2-4.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-05 04:57:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 768177 None None None 2016-06-29 12:44:41 UTC

Description Thorsten Leemhuis 2016-06-27 14:40:38 UTC
Description of problem:
The paragraph style gets switched back to "Default style" when I copy a text to the clipboard and then paste it

Version-Release number of selected component (if applicable):
libreoffice-core-5.1.4.2-3.fc24

How to reproduce:
* write a word (like "test")
* change the paragraph style to something else (like "text body")
* copy one character of the word to the clipboard
* paste that character somewhere before, in the middle or at the end of the line that contains the word written initially 
-> paragraph style switches back to "Default style"

Additional info:
Not sure if it matters: I'm running libreoffice in a Gnome wayland session

Comment 1 Caolan McNamara 2016-06-28 08:53:55 UTC
Presumably because of trying to run everything through the system clipboard because of the difficulty of detecting if we own it or not under wayland

Comment 2 Caolan McNamara 2016-06-29 12:44:41 UTC
plan b then I guess

Comment 3 Fedora Update System 2016-06-30 12:47:15 UTC
libreoffice-5.1.4.2-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6182a7b901

Comment 4 Fedora Update System 2016-07-02 20:31:05 UTC
libreoffice-5.1.4.2-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6182a7b901

Comment 5 Thorsten Leemhuis 2016-07-04 06:05:10 UTC
(In reply to Fedora Update System from comment #3)
> libreoffice-5.1.4.2-4.fc24 has been submitted as an update to Fedora 24.
> https://bodhi.fedoraproject.org/updates/FEDORA-2016-6182a7b901

This brought bug 1326304 back :-/

Comment 6 Caolan McNamara 2016-07-04 09:13:00 UTC
*** Bug 1352388 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2016-07-05 04:56:55 UTC
libreoffice-5.1.4.2-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Won Young Choi 2016-07-06 01:27:23 UTC
It works good, thanks!


Note You need to log in before you can comment on or make changes to this bug.