Bug 135201 - broken dependency test for yum install when a dependency requires one of the yet to be installed packages
broken dependency test for yum install when a dependency requires one of the ...
Status: CLOSED DUPLICATE of bug 135008
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-10 00:10 EDT by Arenas Belon, Carlo Marcelo
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arenas Belon, Carlo Marcelo 2004-10-10 00:10:06 EDT
Description of problem:
dependency list for install does not include the packages to be
installed and breaks if there is a mutual dependency.

Version-Release number of selected component (if applicable):
2.1.6-1

How reproducible:
always

Steps to Reproduce:
1. install fedora core3 test 2 + patches (fedora development up to Oct
09, 2004)
2. yum install gcc-c++
3.
  
Actual results:
Processing Dependency: libstdc++-devel= 3.4.2 for package: gcc-c++
Finished Dependency Resolution
Error: Requiring package gcc-c++-3.4.2-5.x86_64 not in transaction set
                         nor in rpmdb

Expected results:
package installed

Additional info:
yum install libstdc++-devel works fine, and then yum install gcc-c++
finds its required dependency on the rpmdb and proceeds ok.

it fails even if an exact match for the package is being used on the
installation as shown below :

[root@localhost ~]# yum install libtool-1.5.6-4.x86_64
Setting up Install Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3636/3636
Resolving Dependencies
Processing Dependency: autoconf for package: libtool
Processing Dependency: libtool-libs= 1.5.6-4 for package: libtool
Processing Dependency: automake for package: libtool
Finished Dependency Resolution
Error: Requiring package libtool-1.5.6-4.x86_64 not in transaction set
                         nor in rpmdb
Comment 1 Seth Vidal 2004-10-10 00:11:53 EDT

*** This bug has been marked as a duplicate of 135008 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.