Bug 1352832 - Unable to add User Roles while creating custom button
Summary: Unable to add User Roles while creating custom button
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.5.5
Assignee: Eric Hayes
QA Contact: Niyaz Akhtar Ansari
URL:
Whiteboard: ui:button
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-05 08:34 UTC by Niyaz Akhtar Ansari
Modified: 2016-09-27 08:54 UTC (History)
8 users (show)

Fixed In Version: 5.5.5.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-26 15:36:15 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
screenshot (56.03 KB, image/png)
2016-07-05 08:34 UTC, Niyaz Akhtar Ansari
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 19:28:27 UTC

Description Niyaz Akhtar Ansari 2016-07-05 08:34:25 UTC
Created attachment 1176301 [details]
screenshot

Description of problem:


Version-Release number of selected component (if applicable):
Version: 5.5.5.0.20160628144838_629f93b


How reproducible:
100%

Steps to Reproduce:
1.Navigate to Automate->Customization
2.Click the Buttons Accordion
3.Select any Object Types tree->Click Configuration then Add a new Button 
4.Fill all details 
5.Under Visibility, select User Roles. -> and click on Save 


Actual results:
When selecting user roles and clicked on save button it shows the wrong flash message.

Expected results:
selected user roles should be added after clicking save button 

Additional info:

Comment 2 Harpreet Kataria 2016-07-05 15:52:18 UTC
Eric,

Fix for https://bugzilla.redhat.com/show_bug.cgi?id=1351716 partially fixes the issue. After applying changes in https://gitlab.cloudforms.lab.eng.rdu2.redhat.com/cloudforms/cfme/merge_requests/998, i am now seeing JS error: ReferenceError: event is not defined
http://localhost:3000/assets/miq_ujs_bindings.self.js?body=1
Line 104 when trying to check/uncheck checkboxes.
Let me know if you need help recreating/debugging.

Thanks,
~Harpreet

Comment 4 CFME Bot 2016-07-06 14:48:33 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=1ee8f8a3b9830c46bd71d4e15ce0b98446017d72

commit 1ee8f8a3b9830c46bd71d4e15ce0b98446017d72
Author:     Eric Hayes <eric@erichayes.net>
AuthorDate: Tue Jul 5 10:28:53 2016 -0700
Commit:     Eric Hayes <eric@erichayes.net>
CommitDate: Tue Jul 5 10:50:27 2016 -0700

    Send jQuery event to function
    https://bugzilla.redhat.com/show_bug.cgi?id=1352832

 app/assets/javascripts/miq_ujs_bindings.js | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 5 CFME Bot 2016-07-06 14:48:46 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=3f9d373dd096a3c01f7d37e6224a8ac9d4ca565a

commit 3f9d373dd096a3c01f7d37e6224a8ac9d4ca565a
Merge: 3546010 1ee8f8a
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed Jul 6 10:48:09 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed Jul 6 10:48:09 2016 -0400

    Merge branch 'fix_server_role_form' into '5.5.z'
    
    Fix roles form
    
    Move attemptAutoRefreshTrigger so that it’s always defined (like upstream)
    
    Send the event param to the observe_checkbox listener function.
    
    Fixes:
    
    * Observing checkbox changes was broken under configure/configuration/server roles.
    * Missing param caused `ReferenceError: event is not defined` under Automate in Firefox
    
    Addresses:
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1351716
    https://bugzilla.redhat.com/show_bug.cgi?id=1352832
    
    
    See merge request !998

 app/assets/javascripts/miq_ujs_bindings.js | 15 +++++++++------
 1 file changed, 9 insertions(+), 6 deletions(-)

Comment 7 Niyaz Akhtar Ansari 2016-07-14 05:37:17 UTC
Able to add selected user roles while creating custom button.

Verified in Version 5.5.5.2.20160712144556_629f93b

Comment 9 errata-xmlrpc 2016-07-26 15:36:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html


Note You need to log in before you can comment on or make changes to this bug.