Bug 1351716 - Changes to server roles do not enable save button
Summary: Changes to server roles do not enable save button
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.5.5
Assignee: Eric Hayes
QA Contact: Ramesh A
URL:
Whiteboard:
: 1351479 1351489 1351573 1351916 1352819 1352845 1352904 1352923 1352934 1353314 1353318 1354478 1354589 1354592 (view as bug list)
Depends On:
Blocks: 1352026 1352028
TreeView+ depends on / blocked
 
Reported: 2016-06-30 16:00 UTC by Alex Newman
Modified: 2016-07-28 03:40 UTC (History)
16 users (show)

Fixed In Version: 5.5.5.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1352026 1352028 (view as bug list)
Environment:
Last Closed: 2016-07-26 15:38:33 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 19:28:27 UTC

Description Alex Newman 2016-06-30 16:00:11 UTC
Description of problem:
Changes to server roles do not enable save button

Version-Release number of selected component (if applicable):
5.5.5.0

How reproducible:
very

Steps to Reproduce:
1.enable/disable a server role
2.
3.

Actual results:
save button not enabled

Expected results:
save button enabled

Additional info:

Comment 3 Dan Clarizio 2016-06-30 16:30:17 UTC
*** Bug 1351479 has been marked as a duplicate of this bug. ***

Comment 4 Dan Clarizio 2016-06-30 16:33:23 UTC
*** Bug 1351489 has been marked as a duplicate of this bug. ***

Comment 8 Harpreet Kataria 2016-07-05 14:48:57 UTC
*** Bug 1352904 has been marked as a duplicate of this bug. ***

Comment 10 Harpreet Kataria 2016-07-05 15:50:24 UTC
*** Bug 1352845 has been marked as a duplicate of this bug. ***

Comment 11 CFME Bot 2016-07-06 14:48:37 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=a5416ffecec55122c3d0e0831b8664a4a35e91b5

commit a5416ffecec55122c3d0e0831b8664a4a35e91b5
Author:     Eric Hayes <eric@erichayes.net>
AuthorDate: Thu Jun 30 14:04:15 2016 -0700
Commit:     Eric Hayes <eric@erichayes.net>
CommitDate: Thu Jun 30 14:04:15 2016 -0700

    Move attemptAutoRefreshTrigger so that it’s always defined (like upstream)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1351716

 app/assets/javascripts/miq_ujs_bindings.js | 13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)

Comment 12 CFME Bot 2016-07-06 14:48:42 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=3f9d373dd096a3c01f7d37e6224a8ac9d4ca565a

commit 3f9d373dd096a3c01f7d37e6224a8ac9d4ca565a
Merge: 3546010 1ee8f8a
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed Jul 6 10:48:09 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed Jul 6 10:48:09 2016 -0400

    Merge branch 'fix_server_role_form' into '5.5.z'
    
    Fix roles form
    
    Move attemptAutoRefreshTrigger so that it’s always defined (like upstream)
    
    Send the event param to the observe_checkbox listener function.
    
    Fixes:
    
    * Observing checkbox changes was broken under configure/configuration/server roles.
    * Missing param caused `ReferenceError: event is not defined` under Automate in Firefox
    
    Addresses:
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1351716
    https://bugzilla.redhat.com/show_bug.cgi?id=1352832
    
    
    See merge request !998

 app/assets/javascripts/miq_ujs_bindings.js | 15 +++++++++------
 1 file changed, 9 insertions(+), 6 deletions(-)

Comment 13 Harpreet Kataria 2016-07-06 16:53:33 UTC
*** Bug 1352819 has been marked as a duplicate of this bug. ***

Comment 14 Harpreet Kataria 2016-07-06 21:01:49 UTC
*** Bug 1352923 has been marked as a duplicate of this bug. ***

Comment 15 Harpreet Kataria 2016-07-06 21:02:00 UTC
*** Bug 1351573 has been marked as a duplicate of this bug. ***

Comment 16 Harpreet Kataria 2016-07-06 21:18:52 UTC
*** Bug 1353318 has been marked as a duplicate of this bug. ***

Comment 17 Harpreet Kataria 2016-07-07 17:36:13 UTC
*** Bug 1353314 has been marked as a duplicate of this bug. ***

Comment 18 Harpreet Kataria 2016-07-07 18:39:30 UTC
*** Bug 1351916 has been marked as a duplicate of this bug. ***

Comment 19 Milan Falešník 2016-07-11 12:40:20 UTC
*** Bug 1352934 has been marked as a duplicate of this bug. ***

Comment 20 Milan Falešník 2016-07-11 16:17:39 UTC
*** Bug 1354478 has been marked as a duplicate of this bug. ***

Comment 22 Ramesh A 2016-07-14 05:50:56 UTC
Good to go.  Verified and working fine in 5.5.5.2.20160712144556_629f93b

Comment 23 Harpreet Kataria 2016-07-18 17:07:10 UTC
*** Bug 1354592 has been marked as a duplicate of this bug. ***

Comment 24 Harpreet Kataria 2016-07-18 17:08:18 UTC
*** Bug 1354589 has been marked as a duplicate of this bug. ***

Comment 26 errata-xmlrpc 2016-07-26 15:38:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html


Note You need to log in before you can comment on or make changes to this bug.