Bug 135365 - Kernel does not see SATA disks (NFORCE3-250)
Kernel does not see SATA disks (NFORCE3-250)
Status: CLOSED DUPLICATE of bug 135302
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-12 05:11 EDT by Jan Christiaan van Winkel
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Christiaan van Winkel 2004-10-12 05:11:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
The kernel for the installer of FC3t3 does not see SATA disks that are
called /dev/hde and /dev/hdg on the same hardware with FC2 (out of the
box).

Hardware:
MSI MSI K8N NEO2 Platinum (NFORCE3-250)
Athlon64 3500+
2xMaxtor 6Y160M0 SATA disk

Dmesg output for FC3t3 installer:

...
NFORCE3-250: IDE controller at PCI slot 0000:00:08.0
NFORCE3-250: chipset revision 162
NFORCE3-250: not 100% native mode: will probe irqs later
NFORCE3-250: 0000:00:08.0 (rev a2) UDMA133 controller
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA
Probing IDE interface ide0...
hdb: BENQ DVD DL DW1600, ATAPI CD/DVD-ROM drive
Using cfq io scheduler
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
Probing IDE interface ide1...
Probing IDE interface ide2...
ide2: Wait for ready failed before probe !
Probing IDE interface ide3...
ide3: Wait for ready failed before probe !
Probing IDE interface ide4...
ide4: Wait for ready failed before probe !
Probing IDE interface ide5...
ide5: Wait for ready failed before probe !
hdb: ATAPI 63X DVD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
ide-floppy driver 0.99.newide


The same dmesg from the FC2 kernel:
NFORCE3S-SATA2: IDE controller at PCI slot 0000:00:09.0
NFORCE3S-SATA2: chipset revision 162
NFORCE3S-SATA2: BIOS didn't set cable bits correctly. Enabling workaround.
NFORCE3S-SATA2: BIOS didn't set cable bits correctly. Enabling workaround.
NFORCE3S-SATA2: 0000:00:09.0 (rev a2) UDMA133 controller
NFORCE3S-SATA2: 100% native mode on irq 10
    ide2: BM-DMA at 0xcc00-0xcc07, BIOS settings: hde:pio, hdf:pio
    ide3: BM-DMA at 0xcc08-0xcc0f, BIOS settings: hdg:pio, hdh:pio
hde: Maxtor 6Y160M0, ATA DISK drive
ide2 at 0x9e0-0x9e7,0xbe2 on irq 10
hdg: Maxtor 6Y160M0, ATA DISK drive
ide3 at 0x960-0x967,0xb62 on irq 10
NFORCE3S-SATA: IDE controller at PCI slot 0000:00:0a.0
NFORCE3S-SATA: chipset revision 162
NFORCE3S-SATA: 0000:00:0a.0 (rev a2) UDMA133 controller
NFORCE3S-SATA: 100% native mode on irq 5
    ide4: BM-DMA at 0xe400-0xe407, BIOS settings: hdi:pio, hdj:pio
    ide5: BM-DMA at 0xe408-0xe40f, BIOS settings: hdk:pio, hdl:pio
hde: max request size: 1024KiB
hde: 320173056 sectors (163928 MB) w/7936KiB Cache, CHS=19929/255/63
 hde: hde1 hde2
hdg: max request size: 1024KiB
hdg: 320173056 sectors (163928 MB) w/7936KiB Cache, CHS=19929/255/63
 hdg: hdg1 hdg2
hdb: ATAPI 40X DVD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20


Version-Release number of selected component (if applicable):
installer kernel for FC3t3

How reproducible:
Always

Steps to Reproduce:
1.Boot from FC3t3 installer DVD
2.
3.
    

Actual Results:  no disks seen

Expected Results:  there should be two disks seen

Additional info:
Comment 1 Bill Nottingham 2004-10-12 09:40:11 EDT

*** This bug has been marked as a duplicate of 135302 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.