Bug 135302 - Install program does not recognise SATA hard disks -> unable to install
Install program does not recognise SATA hard disks -> unable to install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
: 135336 135365 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-11 16:43 EDT by Jussi Mikkola
Modified: 2015-01-04 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 01:30:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jussi Mikkola 2004-10-11 16:43:09 EDT
Description of problem: The installation software does not recognice
the nvidia nforce 250 chipset or the SATA drives. It complains that it
does not find any hard disk -> unable to install.

Version-Release number of selected component (if applicable):


How reproducible: every time


Steps to Reproduce:
1.Put FC3 test 3 CD 1 in the CD drive and boot the computer
2.There is first a screen complaining that there is no harddisk. 
3.Unable to partition harddrive, since no harddisk exists/drivers for it.
  
Actual results: Installation stops.


Expected results: Able to install, since FC2 was able to install, so
FC3 should support the nvidia sata chipset too?


Additional info:

I installed FC2 (x86_64), and that was ok. Then I tried to update to
newest kernel, and that failed. 

I am using linux software raid on all partiotions.

The computer has epox 8HDA5J motherboard with nforce 250 chipset and 2
seagate 200G sata drives.
Comment 1 Bill Nottingham 2004-10-11 21:56:17 EDT
*** Bug 135336 has been marked as a duplicate of this bug. ***
Comment 2 Michel Alexandre Salim 2004-10-12 03:04:50 EDT
FYI, just tried the i386 DVD and it produces the same result.
Comment 3 Bill Nottingham 2004-10-12 09:40:20 EDT
*** Bug 135365 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2004-10-12 15:40:08 EDT
sata_nv added to module-info (by notting)
Comment 5 Michel Alexandre Salim 2004-10-13 03:42:34 EDT
Could the ISOs for test3 be updated, or new boot.isos produced, so
people with nForce SATA chipsets could participate in the FC3 test
program?

Thanks.
Comment 6 Jussi Mikkola 2004-10-13 09:08:58 EDT
What is the file(s) I need to update, so I could try a network install
to see id it works?

Rgs,

Jussi
Comment 7 Jussi Mikkola 2004-10-17 13:02:25 EDT
I made a CD with boot.iso from rawhide, and tried to do a network
install. 

Quite in the beginning there is a message displayed, that sata_nv is
loaded. However, later on, the harddisks are still not recognized, and
I can't install. 

For rawhide, I used
http://ftp.sunet.se/pub/Linux/distributions/fedora/development/x86_64/Fedora

And the latest changes are from 16th. 

Rgs,

Jussi
Comment 8 Jan Christiaan van Winkel 2004-10-17 13:12:59 EDT
Perhaps this has something to do with bug 3352 in the kernel at osdl:
"sata_nv module fails to find drives"
http://bugme.osdl.org/show_bug.cgi?id=3352

Quoting from that page:
[quote]
------- Additional Comment #4 From Chris Osgood  2004-10-07 20:15 -------
Yes, the DK8N is an Iwill board.  Taking out the ATA_FLAG_SATA_RESET
appears to make it work.  The system came up fine with the sata_nv
driver and I'm using it right now.

Is this something specific to this hardware combination?  I was
thinking it is a Seagate SATA issue.  What happens with this code
change, can the drive now not be reset?

I made the following change to kernel 2.6.9-rc3-bk7 sata_nv.c and it
seems to work so far:

--- sata_nv.c_orig      2004-10-07 23:06:40.721827293 -0400
+++ sata_nv.c   2004-10-07 23:10:45.234309240 -0400
@@ -221,7 +221,7 @@
 static struct ata_port_info nv_port_info = {
        .sht            = &nv_sht,
        .host_flags     = ATA_FLAG_SATA |
-                         ATA_FLAG_SATA_RESET |
+                         /*ATA_FLAG_SATA_RESET |*/
                          ATA_FLAG_SRST |
                          ATA_FLAG_NO_LEGACY,
        .pio_mask       = NV_PIO_MASK,
[/quote]

------- Additional Comment #5 From Andrew Chew  2004-10-07 20:21 -------

The BIOS typically does a reset of the SATA phy.  As long as you don't
do any hotplug (which isn't supported by libata yet anyway), this
shouldn't be a  problem.  This still needs to be solved to prepare for
hotplug, though.

You should be safe with this workaround until a proper fix is found.
Comment 9 Jussi Mikkola 2004-10-22 15:20:57 EDT
I tested this with the current developement version, which has 2.6.9
kernel (atleast according to the naming), but I could not install. 

The sata_nv is loaded, but the drives (Seagate sata) are not recognized.

Rgs,

Jussi
Comment 10 Jan Christiaan van Winkel 2004-10-23 06:06:22 EDT
I have success with today's (20041023) rawhide:
# cat /proc/version
Linux version 2.6.9-1.640 (bhcompile@thor.perf.redhat.com) (gcc
version 3.4.2 20041017 (Red Hat 3.4.2-6)) #1 Wed Oct 20 09:49:43 EDT 2004
HW:
MSI MSI K8N NEO2 Platinum (NFORCE3-250)
Athlon64 3500+
2xMaxtor 6Y160M0 SATA disk

(note: scsi0 is my Adaptec controller for my DDS tape unit)

Relevant dmesg output:

sata_nv version 0.03
ACPI: PCI interrupt 0000:00:09.0[A] -> GSI 5 (level, low) -> IRQ 5
PCI: Setting latency timer of device 0000:00:09.0 to 64
ata1: SATA max UDMA/133 cmd 0x9E0 ctl 0xBE2 bmdma 0xCC00 irq 5
ata2: SATA max UDMA/133 cmd 0x960 ctl 0xB62 bmdma 0xCC08 irq 5
nv_sata: Primary device added
nv_sata: Primary device added
ata1: dev 0 cfg 49:2f00 82:7c6b 83:7f09 84:4003 85:7c69 86:3e01
87:4003 88:007f
ata1: dev 0 ATA, max UDMA/133, 320173056 sectors: lba48
ata1: dev 0 configured for UDMA/133
scsi1 : sata_nv
nv_sata: Secondary device added
nv_sata: Secondary device added
ata2: dev 0 cfg 49:2f00 82:7c6b 83:7f09 84:4003 85:7c69 86:3e01
87:4003 88:007f
ata2: dev 0 ATA, max UDMA/133, 320173056 sectors: lba48
ata2: dev 0 configured for UDMA/133
scsi2 : sata_nv
  Vendor: ATA       Model: Maxtor 6Y160M0    Rev: YAR5
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 320173056 512-byte hdwr sectors (163929 MB)
SCSI device sda: drive cache: write back
 sda: sda1 sda2
Attached scsi disk sda at scsi1, channel 0, id 0, lun 0
  Vendor: ATA       Model: Maxtor 6Y160M0    Rev: YAR5
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sdb: 320173056 512-byte hdwr sectors (163929 MB)
SCSI device sdb: drive cache: write back
 sdb: sdb1 sdb2
Attached scsi disk sdb at scsi2, channel 0, id 0, lun 0
Comment 11 Marius Staring 2004-11-11 04:38:07 EST
I also have a problem installing FC2 and FC3 on my pc:
a Dell Dimension 8400, with a WD Raptor 74GB SATA harddisk (BIOS
setting to AHCI).

Anaconda does not recognize the harddisk and upon partitioning
installation stops.

Regards,

Marius Staring
Comment 12 Chris Wash 2004-11-12 17:27:51 EST
I'm having the same issue with a WD Raptor 74GB SATA HDD, AMD64 3000+
and MSI motherboard.

SATA drivers are loaded before Anaconda starts, but the drive is not
being recognized by Anaconda.
Comment 13 Matt Rosencrantz 2004-11-14 02:52:05 EST
Has anyone tried out Jan Christiaan's suggestion?  If someone with a
working FC3 installation on x86_64 could edit the source code and send
me, say, a driver disk, I would be happy to give it a go.  By the way
is there any documentation on how to build those driver disks?

Matt Rosencrantz
Comment 14 Jussi Mikkola 2004-11-14 10:59:10 EST
I installed an additional 40G IDE drive, and installed FC3 on it.
However, I still could not find the Seagate SATA drives. 

I then downloaded the kernel source rpm, compiled that and installed
the new driver with the proposed fix. No more success than before. Can
be, that I have made something wrong, but it boots just like before,
so I would guess, that there is something else wrong with it.

Rgs,

Jussi
Comment 15 Jan Christiaan van Winkel 2004-11-18 00:27:22 EST
Just like the Rawhide version, FC3 installs and boots fine on my
harware (see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=135302#c10 )

Thus, for *my* hardware, the problem is solved. 
Comment 16 Michel Alexandre Salim 2004-11-18 00:36:04 EST
Same here
Comment 17 Philip Long 2004-11-18 07:30:30 EST
I have the same problem as every one else here

My hardware is:
Gigabyte GA-K8NS Motherboard (chipset nVidia nForce3 250) 
200G Maxtor DMax+10 SATA150/7200/8M Hard Drive

Unlike Jan Christiaan van Winkel I have the problem in FC3
Comment 18 Pavel Urban 2004-12-10 12:55:58 EST
The same problem here. I was able to install FC2, but not FC3. The
latest kernel (2.6.9-1.6_FC2) for FC2 doesn't work, either. I've tried
to recompile and end up with SATA controller detected, but then I've
got this message:

ata1 is slow to respond, please be patient

... and after some time the boot process continued, ending with panic
due to classic 'no root'. 

MSI K7N2 Delta2-LSR, nForce2 chipset, Seagate Barracuda 7200.7 PLUS
200G SATA drive, Athlon XP 2600+ CPU
Comment 19 Eric Fallon 2004-12-27 23:04:50 EST
The Fedora Core 3 x86_64 does not recognize my hard drive either:

Steps to Reproduce:
1. Put FC3 CD 1 in the CD drive and boot the computer
2. Installation says it's loading sata_nv. 
3. There is first a screen complaining that there is no harddisk. 

My hardware is:
Nvidia Nforce 3 250 chipset
Seagate Barracuda 120GB 7200 (SATA)
Athlon 64 3000+ CPU
Comment 20 Jussi Mikkola 2005-01-10 18:48:08 EST
My bug is fixed with kernel 2.6.10. Although I cannot propably install
on a pure sata system, but I have a pata disc that I can use in
installation.

Others, who have problems, I recommend you try the 2.6.10 kernel.


Rgs,

Jussi
Comment 21 Pavel Urban 2005-01-14 12:49:43 EST
Seems like my problem is solved by the latest kernel update, too. I've
installed through FC2 CD; you can try it the same way. Didn't try to
update to FC3, but it should work.
Comment 22 Erik 2005-04-22 06:29:08 EDT
I Have the same experience: 

try to install FC3 x86_64 on 

ASUS K8N mobo with nForce3 250
Seagate ST3160827AS 160G SATA

I also get sata_nv loaded, but my hd not recognised during install. Just like in
Jussi says in #20, I have seen in other forums, eg
http://www.amdzone.com/modules.php?op=modload&name=PNphpBB2&file=viewtopic&t=2300

[quote]
OK.
I'm guessing here... hut here goes.
One of the biggest changes in 2.6.8 is the move to libata (instead of using the
normal IDE for SATA).
However, this means that SATA drives are now /dev/sdxx instead of /dev/hdxx. 
[/quote]


Also, Many people seems to have been sucessful with FC2 where they failed with FC3

Note You need to log in before you can comment on or make changes to this bug.