This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 135445 - system-config-services fails with nonblockingreader module not found
system-config-services fails with nonblockingreader module not found
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
: 135478 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-12 15:06 EDT by Clyde E. Kunkel
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 17:06:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Clyde E. Kunkel 2004-10-12 15:06:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041012

Description of problem:
When invoking system-config-services as root, get the following:

Traceback (most recent call last):
  File "/usr/sbin/system-config-services", line 53, in ?
    import servicemethods
  File "/usr/share/system-config-services/servicemethods.py", line 28,
in ?
    import nonblockingreader
ImportError: No module named nonblockingreader



Version-Release number of selected component (if applicable):
0.8.12-1

How reproducible:
Always

Steps to Reproduce:
1.as root at a terminal enter system-config-services or select from menu
2.
3.
    

Actual Results:  as stated above

Expected Results:  services gui showing running/stopped services, etc

Additional info:

Updated FC3T2 to FC3T3 on 10/11/04 and updated with todays rawhide.
Comment 1 Nils Philippsen 2004-10-12 17:06:43 EDT
Thinko on my behalf, fixed in 0.8.14-1.
Comment 2 Nils Philippsen 2004-10-13 04:54:02 EDT
*** Bug 135478 has been marked as a duplicate of this bug. ***
Comment 3 Clyde E. Kunkel 2004-10-13 11:12:51 EDT
Works now after todays up2date.  Thanks.  Noticed deprecation warnings:

/usr/sbin/system-config-services:197: DeprecationWarning:
  self.btnStart = self.tbrSave.append_item(_("Start"), _("Start"),
None, icon, self.on_btnStart_clicked, None)
/usr/sbin/system-config-services:201: DeprecationWarning:
  self.btnStop = self.tbrSave.append_item(_("Stop"), _("Stop"), None,
icon, self.on_btnStop_clicked, None)
/usr/sbin/system-config-services:205: DeprecationWarning:
  self.btnRestart = self.tbrSave.append_item(_("Restart"),
_("Restart"), None, icon, self.on_btnRestart_clicked, None)
/usr/sbin/system-config-services:207: DeprecationWarning:
  self.tbrSave.insert_space(3)
/usr/sbin/system-config-services:211: DeprecationWarning:
  self.btnSave = self.tbrSave.append_item(_("_Save"), _("Save"), None,
icon, self.on_mnuSave_clicked, None)
/usr/sbin/system-config-services:216: DeprecationWarning:
  self.btnRevert = self.tbrSave.append_item(_("_Revert"), _("Revert"),
None, icon, self.on_mnuRevert_clicked, None)
(0, 'N 5')
[
Comment 4 Nils Philippsen 2004-10-13 11:33:51 EDT
This issue is already known, but can only be fixed with some serious
reworking of the UI, i.e. only after FC3 (see bg #134978).

Note You need to log in before you can comment on or make changes to this bug.