Bug 135454 - Window List doesn't show Windows on secondary Screen
Summary: Window List doesn't show Windows on secondary Screen
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: libwnck   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
: 137171 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-12 19:54 UTC by lars@bistromatic.de
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 21:47:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description lars@bistromatic.de 2004-10-12 19:54:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040930

Description of problem:
I'm using a nvidia card with two connected screens (TwinView).
So one gnome-workspace consists of two screens.
The Window List applet shows only windows on the same screen.
It should show every window on the hole workspace
(or every open window on all workspaces).

FWIW the Window Selector applet lists every window on both screens.
The Window List applet works as expected in fedora core 2 using
the same nvidia-driver and the same xorg.conf.

Version-Release number of selected component (if applicable):
gnome-panel-2.8.0.1-3

How reproducible:
Always

Steps to Reproduce:
1. Connect to screens using an nvidia card with TwinView
2. Open a gnome session
3. Open one window on every screen

    

Actual Results:  Window List applet shows only the window on the same
screen.

Expected Results:  Should show both windows.

Additional info:

Comment 1 Mark McLoughlin 2004-10-12 21:47:30 UTC
Yeah - the window list was modified to only show windows on the
current monitor since that makes more sense on the default setup where
you have a window list on each monitor.

See upstream bug report where we're planning on showing all windows in
the case where theres only a single window list:

  http://bugzilla.gnome.org/show_bug.cgi?id=154040

Comment 2 Mark McLoughlin 2004-10-28 14:08:04 UTC
*** Bug 137171 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.