Bug 135487 - HTTP config won't save and exit
HTTP config won't save and exit
Product: Fedora
Classification: Fedora
Component: system-config-httpd (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Depends On: 119849
  Show dependency treegraph
Reported: 2004-10-12 19:57 EDT by parq
Modified: 2015-03-04 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-20 10:37:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description parq 2004-10-12 19:57:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)

Description of problem:
After run it as root or user (prompting for SU pass), all changes can
be made to the http configuration.

Then the 'OK' is pressed and a confirmation dialog (Save and exit?) is
pressed 'OK', nothing happens. The configuration tools is still there
and the changes aren't saved.

I tried to comment the '<>' in line 10 of
/usr/share/system-config-httpd/httpd.conf.xsl, as said in the #14 of
bug    #119849, but it's still not working.

I search and do everything as said the following bugs, but it's not fixed:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Open the tool system-config-httpd
2. Make changes
3. Save the changes and exit (it won't work)

Actual Results:  The changes aren't saved and the tool is still there!

Expected Results:  To save the changes and exit.

Additional info:

Traceback (most recent call last):
  File "/usr/share/system-config-httpd/ApacheConf.py", line 273, in
    if not control.write():
  File "/usr/share/system-config-httpd/ApacheControl.py", line 63, in
    return stack.apache.write(force)
  File "/usr/share/system-config-httpd/ApacheGizmo.py", line 770, in write
    return ApacheBase.write (force)
  File "/usr/share/system-config-httpd/ApacheBase.py", line 4346, in write
  File "/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/Processor.py",
line 178, in appendStylesheet
    sty = self._styReader.fromSrc(iSrc, extElements=self.extElements)
line 160, in fromSrc
    stylesheet =  self._parseSrc(new_source)
line 180, in _parseSrc
    success = self.parser.ParseFile(src.stream)
line 348, in startElement
    raise e
Ft.Xml.Xslt.XsltException: In stylesheet
file:///usr/share/system-config-httpd/httpd.conf.xsl, line 2, column 0:
Invalid number attribute value '1.0'
Comment 1 Phil Knirsch 2004-10-13 09:02:47 EDT
That looks like a different problem:

Line 2 looks like this:

<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"

And it's obviously complaining about the 1.0, but that has been there
for ages.

Could you please deinstall system-config-httpd completelt and
reinstall it and see if the problem persists?

You might need to update 4Suite and/or libxml too.

Read ya, Phil
Comment 2 Phil Knirsch 2004-10-20 10:37:50 EDT
Closing as all relevant stuff has been discussed here:


Read ya, Phil
Comment 3 parq 2004-10-30 07:10:50 EDT
ok. working

i've changed /usr/share/system-config-httpd/httpd.conf.xsl:

- from: <xsl:stylesheet
xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
- to:  <xsl:stylesheet
xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1">

system info:
fedora core 2


Note You need to log in before you can comment on or make changes to this bug.