Bug 135573 - Cannot get out of fullscreen on qt apps
Summary: Cannot get out of fullscreen on qt apps
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 136932 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-13 16:08 UTC by Edward Rousseau
Modified: 2015-04-12 23:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 18:15:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Edward Rousseau 2004-10-13 16:08:48 UTC
Description of problem: When selecting "fullscreen" either by button
or by menu item for a qt application that has this option (kstars for
example) You can enter Fullscreen mode but "exit" fullscreen does not
change the app back to it's original sizing. 

Additionally, the first time I fullscreen an app it sizes improperly
with the menu bar being cut off. Subsequent fullsceen sizings operate
properly. Additionally, if I run something like kstars under GNOME
with panels on the top and bottom of the screen, the fullscreen app
obscures the top panel but slices into the bottom panel.


Version-Release number of selected component (if applicable):
qt-3.3.3-7

How reproducible:
Always


Steps to Reproduce:
1. Open a qt app that has a fullscreen option (kstars, kig)
2. Go to fullscreen (button, menu)
3. Select exit fullscreen

Actual results:
App remains fullscreen

Expected results:
App should return to previous window size

Additional info:

Comment 1 Ngo Than 2004-10-18 14:12:17 UTC
sorry i cannot reproduce this problem in fc3test3 with qt-3.3.3-7 and
metacity-2.8.5-2. it works for me

Comment 2 Edward Rousseau 2004-10-20 21:55:36 UTC
Still broken on x86_64: (confirmed both on Opteron and EM64T) 

qt-3.3.3-8
metacity-2.8.5-2

This seems to work on i386 so it is looks like it is x86_64 specific.

Comment 3 Ngo Than 2004-11-04 17:01:28 UTC
*** Bug 136932 has been marked as a duplicate of this bug. ***

Comment 4 Ngo Than 2004-11-09 18:15:18 UTC
it's now fixed in qt-3.3.3-9.1 or newer.


Note You need to log in before you can comment on or make changes to this bug.