Bug 135577 - show details on boot has corrupted display for the first few boot messages
show details on boot has corrupted display for the first few boot messages
Status: CLOSED DUPLICATE of bug 192604
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 12:58 EDT by Matthew Lenz
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-09 00:17:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Lenz 2004-10-13 12:58:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040806 Firefox/0.9.3

Description of problem:
When booting up if I hit enter to show the boot details the first few
lines of ouput are jumbled together and corrupted.

I've seen this with fc3t2 as well.  It happens on multiple machines
with different graphics hardware.  It doesn't actually look like a
problem with the graphics.  It looks like a problem with rhgb.  Its
almost like its not sending a line feed properly or something.

Version-Release number of selected component (if applicable):
0.13.5-2

How reproducible:
Always

Steps to Reproduce:
1. boot
2. hit enter to see boot details once in graphical mode
3. watch for corrupted lines at top of screen
    

Actual Results:  first few boot messages are jumbled together

Expected Results:  display all boot messages correctly

Additional info:

ati included open source driver in an ibm laptop
nvidia commercial driver with a GF5900ultra
Comment 1 Bill Nottingham 2004-10-13 16:49:41 EDT
What locale?
Comment 2 Matthew Lenz 2004-10-13 17:50:16 EDT
i just hit 'next' through the installer using all the English defaults.
Comment 3 Daniel Veillard 2004-10-14 16:30:06 EDT
I have tried rhgb on Matrox, ATI, Dell laptop with either 
opensource or binary Nvidia driver and didn't see the problem myself.
Since it comes from very early on, either
  1/ it's an rhgb bug around the new rhgb-console output
  2/ it's a weird vte initialization
  3/ for some reason the initscripts drop garbage in rhgb-console
  4/ this is some newline handling bug for rhgb-console handling
Seems 4/ is the most likely, but I don't fully understand what
is being seen
  "jumbled together and corrupted"
is not very precise. Some kind of dump of the text seen would be
better,

Daniel
Comment 4 Matthew Lenz 2004-10-14 16:55:45 EDT
is there any kind of screen capture capability in rhgb?
Comment 5 Daniel Veillard 2004-10-15 03:42:38 EDT
no, rhgb starts on a very very minimal system.

Daniel
Comment 6 Michael Schwendt 2004-10-20 07:19:00 EDT
Same here. The first few lines of initscript output in detailed rhgb
screen overwrite eachother and are printed in different order than
when booting in text mode. It's as if no linefeeds are executed. After
"Enabling local filesystem quotas:" everything is okay here.
Comment 7 Miloslav Trmač 2006-07-09 00:17:25 EDT
Caused by a bug in initscripts, should be fixed in next initscripts release.

*** This bug has been marked as a duplicate of 192604 ***

Note You need to log in before you can comment on or make changes to this bug.