Bug 192604 - rhgb overprints lines (bug in /etc/init.d/functions)
Summary: rhgb overprints lines (bug in /etc/init.d/functions)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 135577 (view as bug list)
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-05-21 20:28 UTC by Tony Nelson
Modified: 2014-03-17 02:59 UTC (History)
2 users (show)

Fixed In Version: 8.37-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-23 09:43:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tony Nelson 2006-05-21 20:28:01 UTC
Description of problem:
rhgb overprints several lines near the start of its output.  It probably
overprints all lines that are printed by action().

Version-Release number of selected component (if applicable):
initscripts-8.31.1-1.i386

How reproducible:
Every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
In action(), one of the "echo"s is missing redirection.  Apply this patch:

--- /etc/init.d/functions~      2006-02-14 13:41:21.000000000 -0500
+++ /etc/init.d/functions       2006-05-21 16:19:25.000000000 -0400
@@ -447,7 +447,7 @@ action() {
         echo_failure > /etc/rhgb/temp/rhgb-console
        [ -x /usr/bin/rhgb-client ] && /usr/bin/rhgb-client --details=yes
       fi
-      echo
+      echo > /etc/rhgb/temp/rhgb-console
   fi
   return $rc
 }

Comment 1 Miloslav Trmač 2006-07-09 04:17:47 UTC
*** Bug 135577 has been marked as a duplicate of this bug. ***

Comment 2 Miloslav Trmač 2006-07-09 04:19:39 UTC
Fixed in CVS.  Thanks for the patch.


Note You need to log in before you can comment on or make changes to this bug.