Bug 1356019 - LOGO and Docs links on OSE all pointed to ORIGIN
Summary: LOGO and Docs links on OSE all pointed to ORIGIN
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Steve Goodwin
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks: 1388798 1413823
TreeView+ depends on / blocked
 
Reported: 2016-07-13 09:41 UTC by Yadan Pei
Modified: 2017-01-17 03:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1388798 (view as bug list)
Environment:
Last Closed: 2016-09-19 13:36:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Yadan Pei 2016-07-13 09:41:28 UTC
Description of problem:
In 3.3 installed env, LOGO and DOC links are all ORIGIN specified

Version-Release number of selected component (if applicable):
openshift v3.3.0.4
openshift-ansible-3.3.1-1.git.2.57a2f34.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install an ose-3.3 env with deployment_type=openshift-enterprise setting in ansible inventory
2. Check OSE 3.3 web console

Actual results:
2. LOGO and DOC links are all pointing to ORIGIN

Expected results:
2. OSE env should have everything customized as OpenShift Enterprise

Additional info:

Comment 1 Troy Dawson 2016-08-01 21:48:04 UTC
This has been merged and is in OSE v3.3.0.13 or newer.

Comment 2 Jessica Forrester 2016-08-01 23:11:37 UTC
Only the oauth/login page changes have merged, the doc links and the logo within the console code aren't in yet.

Comment 3 Jessica Forrester 2016-08-15 13:10:59 UTC
This should all be fixed now

Comment 4 Jessica Forrester 2016-08-15 13:11:41 UTC
Also be aware the docs links will 404 since the rebranding of the URLs to container platform instead of enterprise hasn't gone live yet.

Comment 5 Yadan Pei 2016-08-16 05:54:42 UTC
Checked against v3.3.0.19

LOGO in login/oauth is changed to OpenShift Container Platform
DOC links are pointing to https://docs.openshift.com/container-platform/3.3/*


The Logo and Links are right now, move to VERIFIED


Note You need to log in before you can comment on or make changes to this bug.