Bug 13569 - latin1 chars don't work in emacs-nox while in X
Summary: latin1 chars don't work in emacs-nox while in X
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: emacs   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
: 21345 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-07 12:43 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-25 17:13:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-07-07 12:43:57 UTC
Special characterss, e.g. with keymap fi-latin1, only produce beeps in
emacs-nox while using it from X.  Setting locales won't work.  Reportedly,
emacs-nox works from console.

Comment 1 Christian Rose 2000-07-19 18:09:05 UTC
I've confirmed this behavior. emacs-nox works "automagically" from console with
latin1 keyboard characters (even with LANG=C) but doesn't work with these
characters from X.


Comment 2 Pekka Savola 2000-07-24 16:23:44 UTC
As this happens with RH6.2 too, I mentioned this to emacs-bugs.  Consensus seems
to be that this isn't easily fixable, and most don't consider it a bug at all.

Also, there might be a problem with xterm's keyboard definition.

This was, I think, the best response ( > == me):
-----
>After inserting the following commands it seems to work:
>
>(set-terminal-coding-system 'iso-latin-1)
>(set-language-environment "Latin-1")
>(set-keyboard-coding-system 'iso-latin-1)
>
>Without terminal-coding-system, it'll just print question marks.
>
>However, getting this to work _like this_ wasn't really what I was
>after; it did work with my site-start.el hack anyway.  I want to get this
>bug fixed so I don't need to distribute site-starl.el at all (and people
>can use it themselves if they want).
>
>Please also note that setting LANG, LC_ALL etc. doesn't have any effect.

If you set LANG to something that ends in "8859-1", such as
fi_FI.ISO-8859-1, Emacs should display Latin-1 characters properly
(try C-q d) also in an xterm. This is documented in the node "General
Variables" in the Emacs Info documentation.

Direct keyboard input of an d still doesn't work, unless you use
set-keyboard-coding-system or the three-line set-input-mode call
someone else posted. This is because the d key in an xterm sends
Meta-D (pressing Alt-D causes xterm to send the exact same byte
sequence to Emacs), and because Emacs can't distinguish between you
pressing Alt-D and d, it thinks, by default, that you wanted M-d.
After the set-keyboard-coding-system or set-input-mode, Alt-D produces
an d instead of M-d (kill-word); you can't get both to work without
modifying xterm's encoding settings.
-----



Comment 3 Trond Eivind Glomsrxd 2000-08-19 19:15:33 UTC
See above - some of the emacs developers thinks of this as feature. Anyway, easy
work around is to install emacs-X11.

Comment 4 Pekka Savola 2000-08-19 19:23:59 UTC
Please note that that specific work around is not possible in certain
situations.  Most important of these is administering a server system (no
possibility to install emacs-X11) from your X11-enabled workstation using SSH.

You can set up keymaps etc. in .emacs or site-start file though.




Comment 5 Trond Eivind Glomsrxd 2000-11-27 23:05:06 UTC
*** Bug 21345 has been marked as a duplicate of this bug. ***

Comment 6 Trond Eivind Glomsrxd 2000-11-27 23:05:50 UTC
*** Bug 21345 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.