Bug 21345 - cannot use accented characters with emacs
cannot use accented characters with emacs
Status: CLOSED DUPLICATE of bug 13569
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-26 07:11 EST by hannu.laurila
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-27 18:03:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hannu.laurila 2000-11-26 07:11:30 EST
I am unable to type scandinavian characters (part of Latin-1 character set)
in emacs
when launching it using 'emacs -nw file.txt'. 

When emacs pops out an X-window (start using 'emacs file.txt'),
scandinavian characters work correctly.

Characters I tried include d (a with two dots) and v (o with to dots).
Characters seems to
be interpreted as some control sequences - for example, when typing d (ae,
a with two dots), the current word is deleted.

I live in Finland but my installation and settings specify English.
However, setting LANG=fi_FI and LC_CTYPE=fi_FI did not seem to help the
problem.

The problem can be fixed by creating /usr/share/emacs/site-lisp/default.el
with the following content:

(set-input-mode (car (current-input-mode))
                (nth 1 (current-input-mode))
                0)
(standard-display-european 1)

A better fix may exist but I think the default behaviour should be to
support 8-bit Latin-1 characters correctly with no complex configuration
modifications like the one presented above.

Configuration information:

$ cat /etc/redhat-release
Red Hat Linux release 7.0 (Guinness)

$ rpm -q emacs emacs-X11 glibc 
emacs-20.7-17
emacs-X11-20.7-17
glibc-2.2-5

That is, a Red Hat 7 system with all fixes as of 2000-11-25 applied.
Comment 1 Trond Eivind Glomsrxd 2000-11-27 18:03:33 EST
Verified... works fine in console and works fine in X, but not in console mode
in X. The above workaround can't be used, as it restricts Emacs to work with one
set of characters.
Comment 2 Trond Eivind Glomsrxd 2000-11-27 18:05:53 EST

*** This bug has been marked as a duplicate of 13569 ***

Note You need to log in before you can comment on or make changes to this bug.