Bug 13574 - LNE100TX Nic doesn't work in installer
LNE100TX Nic doesn't work in installer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
:
: 16652 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-07 15:37 EDT by Dale Lovelace
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 22:20:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dale Lovelace 2000-07-07 15:37:20 EDT
Supposed to be a "tulip" according to
http://www.linksys.com/support/support.asp?spid=25 I gave one of these
cards to Dr. Mike.
Comment 1 Michael Fulbright 2000-07-12 16:27:16 EDT
Please test...
Comment 2 Brock Organ 2000-07-13 14:26:10 EDT
verified that this card is not found during autoprobe, and doesn't respond to
tulip or old_tulip drivers in beta3 ...

it also doesn't respond to autoprobe, tulip or old_tulip in 6.1, 6.2 ...

% lspci ; lspci -n
00:0b.0 Ethernet controller: Bridgecom, Inc: Unknown device 0985 (rev 11)
00:0b.0 Class 0200: 1317:0985 (rev
11)
Comment 3 Dale Lovelace 2000-08-19 12:52:11 EDT
Looks like it needs the .92 version of the Tulip driver and we provide .91.

ftp://ftp.scyld.com/pub/network/tulip.c

  Adding johnsonm to the cc: list so maybe we can get this included.
Comment 4 Brock Organ 2000-08-19 13:43:16 EDT
verified this is still unresolved in post-RC1 tree (qa0819.0) ...

(ie the card still does NOT respond to tulip or old_tulip drivers in tree)
Comment 5 Pekka Savola 2000-08-19 14:21:19 EDT
Regarding tulip drivers.. please also note that the current driver and Don's
latest 0.92 driver is flawed w/ forced full duplex operation under certain
conditions/cards.

An example of these is D-Link DFE-570TX, a cheap (250$) quad
ethernet.  Works fine now with tweaked drivers (below).

This was flawed even with the latest Don Becker release (0.92) from Apr 2000.
It has to be patches ad follows (or the driver in
ftp://ftp.scyld.com/pub/network/test/ used)

-------------------
The correction is around line 863.
Note that it fixes two problems.  The code must *clear* the bits first!

        /* Enable autonegotiation: some boards default to off. */
        mdio_write(dev, phy, 0, mii_reg0 |
                   (tp->full_duplex ? 0x1100 : 0x1000) |
                   (media_cap[tp->default_port]&MediaIs100 ? 0x2000:0));
___
        /* Configure the xcvr: some boards default to autonegotiation off. */
        mdio_write(dev, phy, 0, (mii_reg0 & ~0x3100) |
                   (tp->full_duplex ? 0x0100 : 0x0000) |
                   ((media_cap[tp->default_port] & MediaIs100)
                    ? 0x2000 : 0x1000));
-------------------

This was given by Don Becker.  This was discussed on linux-net on about
19th Jul.

Comment 6 Daniel Powell 2000-08-19 15:41:32 EDT
This also breaks with the NetGear FA311
Comment 7 Alan Cox 2000-08-20 06:34:06 EDT
The NetGear FA311 isnt relevant to this . That isnt a tulip card but a for the
moment unsupported natsemi device
Comment 8 Michael K. Johnson 2000-08-20 16:46:14 EDT
To make a change this significant to such a commonly-used driver,
the change would have had to have been made before a public beta
where a relatively large group of people would test it, or in a
stable kernel release from Alan (again, a large group of people
would test it).  There are a lot of variants on the tulip chip
out there, and to change any tulip driver significantly without
time for lots of testing would likely cause too many problems --
as evidenced by pekkas's note that Donald's driver from 4 months
ago is known not to be sufficiently stable (and fixing one bug
wouldn't be enough to make us confident in the change).

Therefore, I'm regretfully deferring this.  :-(
Comment 9 Michael K. Johnson 2000-08-21 10:47:33 EDT
*** Bug 16652 has been marked as a duplicate of this bug. ***
Comment 10 Arjan van de Ven 2001-03-07 03:38:22 EST
Please try RC2 on this card.

Note You need to log in before you can comment on or make changes to this bug.