Bug 135741 - Default kernel & kernel modules do not provide ntfs support
Default kernel & kernel modules do not provide ntfs support
Status: CLOSED DUPLICATE of bug 65749
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-14 16:00 EDT by don
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description don 2004-10-14 16:00:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
The default kernel does not include support for read-only ntfs.

I know it's a small thing. Not everyone has ntfs partitions. And
someone who wants the module can go to the source code and compile the
module. Except it's quite a hassle to get the distribution kernel
source to compile a kernel module that will work, basically requires
junking the default kernel and going with a new one just because the
distributed kernel didn't have that option set to include ntfs support
as a module. Just set the option, don't even have to include the
module, just make it possible to compile the module as-is with the
source code provided.

Note: Yes of course I'm talking about read-only access. 

Thanks

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Check /lib/modules/*/kernel/fs/ntfs*
2. Try to mount an ntfs partition
3.
    

Actual Results:  System doesn't have ntfs support

Expected Results:  System should find ntfs module

Additional info:
Comment 1 Pekka Pietikäinen 2004-10-23 08:14:50 EDT

*** This bug has been marked as a duplicate of 65794 ***
Comment 2 don 2004-12-02 00:21:38 EST
65794 unrelated to NTFS. Support still lacking in Core 3 default (667)
kernel and 681_FC3 kernel.

Come on, just select "m" and include it in the default initrd with all
the other modules, and save thousands of people the hassle of getting
it working.
Comment 3 Dave Jones 2004-12-02 00:42:53 EST

*** This bug has been marked as a duplicate of 65749 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:06:18 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.