Bug 65794 - shell stack limit 'unlimited' provides (small) hardcoded size
shell stack limit 'unlimited' provides (small) hardcoded size
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: libc (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-31 14:46 EDT by Suresh Rao
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-31 14:46:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suresh Rao 2002-05-31 14:46:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)

Description of problem:
Setting a shell stack limit of 'unlimited' gives a (small) finite hardcoded 
stacksize from the pthread initialization, but setting a particular value that 
can be quite large honors the setting and gives you that value.  This appears 
very counter-intuitive to users. Could 'unlimited' be set to mean really 
unlimited, or at least very very large.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N/A

Additional info:
Comment 1 Jakub Jelinek 2002-05-31 15:14:45 EDT
Having stack limit set to unlimited is pretty common and this would mean
no threads. 8MB is not that small (sufficient for most threaded apps) and
you can have reasonable amount of threads created at the same time.
If an application has special requirements (be it lots of threads with small
stacks or just a few stack hungry threads), you can always setrlimit before
first pthread_create call.
Comment 2 Pekka Pietikäinen 2004-10-23 08:14:58 EDT
*** Bug 135741 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.