Bug 1357424 - Fedora Media Writer as Primary Downloadable
Fedora Media Writer as Primary Downloadable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bříza
ChangeAcceptedF25, SystemWideChange
:
Depends On: 1057909 1362626 1370054 1370128
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-18 03:58 EDT by Jan Kurik
Modified: 2016-11-22 08:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-22 08:58:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2016-07-18 03:58:23 EDT
This is a tracking bug for Change: Fedora Media Writer as Primary Downloadable
For more details, see: https://fedoraproject.org//wiki/Changes/FedoraMediaWriterAsPrimaryDownloadable

The new Fedora Media Writer that is being finished has an overhauled, more user friendly interface. Because USB sticks are the most common way to install Fedora, it should be the primary download option. It cover the whole installation media creation, it lets the user pick the right flavor of Fedora, downloads its image, and copies it to a USB drive.
Comment 1 Jan Kurik 2016-07-26 00:40:42 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.
Comment 2 Jan Kurik 2016-07-26 01:22:38 EDT
On 2016-July-26, we have reached Fedora 25 Change Checkpoint: Completion deadline (testable).

At this point, all accepted changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be enabled at Change Completion deadline as well.

Change tracking bug should be set to the MODIFIED state to indicate it achieved completeness.

Incomplete and non testable Changes will be reported to FESCo on 2016-July-29 meeting.
Comment 3 Martin Bříza 2016-08-02 08:31:50 EDT
Sorry, I had problems with my mail client and found this mail just now.
The package is testable but it's not included in Fedora, yet.
I will create the package today and go through the package review process and mark the bug as MODIFIED then.
Comment 4 Martin Bříza 2016-08-09 10:30:55 EDT
I pushed FMW to Fedora after the package review. Currently, it's built for F23 and F24. It doesn't build for F25 and above, probably due to some compiler changes. 
I'll fix that tomorrow and build the packages again.
Comment 5 Parag Nemade 2016-08-11 12:03:37 EDT
This looks like now built for Fedora 25 as well in mediawriter-0-1.1git728a879.fc25 build.
Comment 6 Martin Bříza 2016-08-12 03:35:34 EDT
Yes. It's now in Bodhi: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3ddbdc6ebb
Not just for F25 but 24 and 23 too of course. I think F25 push will be most relevant to this Change.
Comment 7 Matthew Miller 2016-08-17 14:01:55 EDT
So are we on track for this to be the primary download on Windows and Mac for the F25 alpha?
Comment 8 Jiri Eischmann 2016-08-19 08:28:36 EDT
(In reply to Matthew Miller from comment #7)
> So are we on track for this to be the primary download on Windows and Mac
> for the F25 alpha?

I don't think we're for alpha, but beta is possible. Fedora Media Writer is pretty much ready for wider testing, Martin is just ironing out smaller things. Dennis received Mac hardware and is figuring out how to build it in Fedora infra, I can't give any estimations for releng unfortunately.

We also need to change the download website. I opened a ticket already for F24, but nothing has seemed to move forward: https://fedorahosted.org/fedora-websites/ticket/384

Any idea, how to push that forward? I don't know an exact process for our websites.
Comment 9 Martin Bříza 2016-08-19 11:44:56 EDT
I'm currently working on providing the final MinGW build - yesterday I talked to Dennis and we figured out the best way would be to build the .exe itself in Koji as a new mingw-* package and then compose the installer using files from multiple downloaded mingw packages.
Comment 10 Jan Kurik 2016-09-29 05:06:11 EDT
On 2016-Sep-27 we reached the "Change Checkpoint: 100% Code Complete Deadline" milestone for Fedora 25 release. At this point all the Changes not at least in "ON_QA" state should be brought to FESCo for review. Please update the state of this bug to "ON_QA" if it is already 100% completed. Please let me know in case you have any trouble with the implementation and the Change needs any help or review.

Thanks, Jan

Note You need to log in before you can comment on or make changes to this bug.