Bug 1370054 - QtQml crashes with complex qml files
Summary: QtQml crashes with complex qml files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mingw-qt5-qtdeclarative
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Erik van Pienbroek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1357424
TreeView+ depends on / blocked
 
Reported: 2016-08-25 08:04 UTC by Martin Bříza
Modified: 2016-10-31 23:45 UTC (History)
1 user (show)

Fixed In Version: mingw-qt5-qtdeclarative-5.6.0-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-31 23:45:10 UTC


Attachments (Terms of Use)
Proposed patch (3.79 KB, patch)
2016-08-25 09:21 UTC, Martin Bříza
no flags Details | Diff
Updated patch (3.30 KB, patch)
2016-08-26 10:13 UTC, Martin Bříza
no flags Details | Diff

Description Martin Bříza 2016-08-25 08:04:43 UTC
Description of problem:
QtQml crashes when loading a complex QML application, like for example the Fedora Media Writer.

Version-Release number of selected component (if applicable):
mingw32-qt5-qtdeclarative-5.6.0-1

How reproducible:
Always

Steps to Reproduce:
1. Compile FMW with mingw32 toolchain
2. Add all necessary libraries (basically just copy /usr/i686-w64-mingw32/sys-root/mingw/bin/*.dll, /usr/i686-w64-mingw32/sys-root/mingw/lib/qt5/plugins/* and /usr/i686-w64-mingw32/sys-root/mingw/share/qt5/qml/* to the directory of the binary) 
3. Try to run it

Actual results:
Crash in QV4

Expected results:
Application starts

Additional info:
A similar issue is reported on [0] with a backtrace from an ARM machine. This happens with our MinGW packages too, though.
The patch suggested in the report fixes our problem, too.


[0] https://bugreports.qt.io/browse/QTBUG-55482

Comment 1 Martin Bříza 2016-08-25 09:21:51 UTC
Created attachment 1193935 [details]
Proposed patch

I'm proposing to patch the problem like this.

I had to add an explicit system zlib link option because a compilation error. This may not be necessary though.

Comment 2 Martin Bříza 2016-08-26 10:13:01 UTC
Created attachment 1194280 [details]
Updated patch

Here is an updated patch for the issue.
Scratch builds are here: http://koji.fedoraproject.org/koji/taskinfo?taskID=15383534

Comment 3 Fedora Update System 2016-09-02 11:11:50 UTC
mingw-qt5-qtdeclarative-5.6.0-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a7f5a94f50

Comment 4 Fedora Update System 2016-09-03 03:53:18 UTC
mingw-qt5-qtdeclarative-5.6.0-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a7f5a94f50

Comment 5 Fedora Update System 2016-10-31 23:45:10 UTC
mingw-qt5-qtdeclarative-5.6.0-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.