Bug 135752 - authd not using proper uid/gid for ident user/group
authd not using proper uid/gid for ident user/group
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: authd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
: 139658 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-14 16:21 EDT by Charles R. Anderson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.4.2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 17:19:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2004-10-14 16:21:23 EDT
Description of problem:

authd's postinstall script creats an ident user and group without
specifying the statically assigned uid/gid values that are documented
in /usr/share/doc/setup-*/uidgid and have been used in the past for
this account with the old pidentd package.  This causes a dynamic
value to be assigned which will be different on new installs vs.
upgrades.  The postinstall script should be changed to specify the
98/98 values documented in uidgid.

postinstall scriptlet (using /bin/sh):
/usr/sbin/adduser -s /sbin/nologin -r ident 2>/dev/null || true

/etc/passwd:
ident:x:100:101::/home/ident:/sbin/nologin

/etc/group:
ident:x:101:

/usr/share/doc/setup-*/uidgid:
ident           98      98      /                       /sbin/nologin
ident

Version-Release number of selected component (if applicable):

authd-1.4.1-1.fc3
Comment 1 Andy Shevchenko 2004-11-17 06:50:41 EST
*** Bug 139658 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.