Bug 139658 - gkrellmd can not started.
Summary: gkrellmd can not started.
Status: CLOSED DUPLICATE of bug 135752
Alias: None
Product: Fedora
Classification: Fedora
Component: authd   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-17 09:31 UTC by Andy Shevchenko
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:07:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andy Shevchenko 2004-11-17 09:31:27 UTC
Description of problem:
Gkrellmd (from gkrellm-daemon) can not started due to gkrellmd user 
is absent.

I discovered the problem and found group conflict.
authd makes system group with id = 101 (if installed before any 
package that use groupadd command in preinstall scriptlet).
However, gkrellm-daemon try to create group with statical id = 101.
If id was busy, group can not be created.

Version-Release number of selected component (if applicable):
authd-1.4.1-1.fc3
gkrellm-2.2.2

How reproducible:
Setup authd on standart installed system.
Then setup gkrellm-daemon. Try to start gkrellmd by service gkrellmd 
start.

Solution:
Reserve some gid for authd (ident) or remove static gid from gkrellm.

Additional info:
$ grep 101 /etc/group /etc/passwd
/etc/group:ident:x:101:
/etc/passwd:ident:!!:100:101::/home/ident:/sbin/nologin

Comment 1 Andy Shevchenko 2004-11-17 11:50:39 UTC

*** This bug has been marked as a duplicate of 135752 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:07:04 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.