Bug 135776 - inputattach spawned multiple times on restart
inputattach spawned multiple times on restart
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
: 135806 (view as bug list)
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-10-14 19:31 EDT by Thomas Zehetbauer
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.20.1-66
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 14:53:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Zehetbauer 2004-10-14 19:31:57 EDT
gpm-1.20.1-61 removes /etc/sysconfig/gpm but still tries to source it
from /etc/init.d/gpm line 44.
Comment 1 Bill Nottingham 2004-10-14 23:29:11 EDT
Fixed in -62.
Comment 2 Eido Inoue 2004-10-15 10:59:39 EDT
*** Bug 135806 has been marked as a duplicate of this bug. ***
Comment 3 Michael Schwendt 2004-10-20 18:31:21 EDT
Cannot confirm that it would be fixed in -62. Every service gpm
restart adds another "/usr/sbin/inputattach -ms /dev/ttyS0 --daemon"
process, which slows down mouse movement and keyboard significantly
until I kill all but one.
Comment 4 Thomas Zehetbauer 2004-10-20 19:58:46 EDT
I can confirm this, each 'gpm restart' causes an additional
inputattach instance to be launched. I have now manually reverted to
directly use the mouse device (only MOUSETYPE and DEVICE in
/etc/sysconfig/mouse).
Comment 5 Michael Schwendt 2004-10-21 11:36:44 EDT
Then let's reopen this.
Comment 6 Bill Nottingham 2004-10-21 12:06:06 EDT
Changing summary, then.
Comment 7 Michael Schwendt 2004-10-21 12:24:49 EDT
It was only bug 135806 (marked duplicate above) which referred to
"inputattach hogs cpu after gpm restart". I didn't see the connection
between these two...
Comment 8 Eido Inoue 2004-10-21 14:53:56 EDT
gpm.init has been modified so that a) inputattach gets shutdown when
gpm is shutdown and b) multiple instances of inputattach should not
get spawned.

Note You need to log in before you can comment on or make changes to this bug.