Bug 135817 - can't start redhat-config-printer
can't start redhat-config-printer
Status: CLOSED DUPLICATE of bug 131563
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 04:50 EDT by Christian Kippe
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 05:03:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Kippe 2004-10-15 04:50:01 EDT
Description of problem:
after upgrading the system with up2date starting redhat-config-printer
says:

[root@u4100034 root]# redhat-config-printer-gui 
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-printer-gui", line 7, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 945, in ?
    queueTree()
  File "/usr/share/printconf/util/queueTree.py", line 102, in __init__
    if cups_import.import_needed ():
  File "/usr/share/printconf/util/cups_import.py", line 200, in
import_needed
    which = which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in
which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment
[root@u4100034 root]#

starting cups says:
[root@u4100034 root]# service cups restart
Stopping cups:                                             [  OK  ]
Starting cups: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import backend
  File "/usr/share/printconf/util/backend.py", line 50, in ?
    which = cups_import.which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in
which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment
                                                           [  OK  ]
[root@u4100034 root]#

/usr/sbin/alternatives --display print says:

print - Status ist auto.
 Link verweist auf /usr/bin/lpr.cups
/usr/bin/lpr.cups - PrioritÀt 40
 Slave print-lp: /usr/bin/lp.cups
 Slave print-lpq: /usr/bin/lpq.cups
 Slave print-lprm: /usr/bin/lprm.cups
 Slave print-lpstat: /usr/bin/lpstat.cups
 Slave print-cancel: /usr/bin/cancel.cups
 Slave print-lpc: /usr/sbin/lpc.cups
 Slave print-cancelman: /usr/share/man/man1/cancel-cups.1.gz
 Slave print-lpman: /usr/share/man/man1/lp-cups.1.gz
 Slave print-lpcman: /usr/share/man/man8/lpc-cups.8.gz
 Slave print-lpqman: /usr/share/man/man1/lpq-cups.1.gz
 Slave print-lprman: /usr/share/man/man1/lpr-cups.1.gz
 Slave print-lprmman: /usr/share/man/man1/lprm-cups.1.gz
 Slave print-lpstatman: /usr/share/man/man1/lpstat-cups.1.gz
Zur Zeit ist die `best' Version /usr/bin/lpr.cups.


Version-Release number of selected component (if applicable):

cups-1.1.17-13.3.13
redhat-config-printer-0.6.47.3.19-1


How reproducible:
install RHAS3 and update it by up2date

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2004-10-15 05:03:56 EDT

*** This bug has been marked as a duplicate of 131563 ***

Note You need to log in before you can comment on or make changes to this bug.