Bug 135895 - after minimal install X tries to spawn, but is not installed
after minimal install X tries to spawn, but is not installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: FC3Blocker 133260
  Show dependency treegraph
 
Reported: 2004-10-15 13:51 EDT by Colin Walters
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 12:34:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
install log (58.66 KB, text/plain)
2004-10-15 16:22 EDT, Colin Walters
no flags Details
anaconda's slitherings (25.23 KB, text/plain)
2004-10-15 16:23 EDT, Colin Walters
no flags Details

  None (edit)
Description Colin Walters 2004-10-15 13:51:57 EDT
User-Agent:       
Build Identifier: 

I did a "minimal" install, and after rebooting I got: Id "x" respawning too
fast... repeatedly.  I suspect this is because firstboot was trying to run, but
I didn't have X installed.  Not sure what the best thing to do here would be.  I
guess just assume people doing minimal installs know what they're doing, and
just not add firstboot to the inittab or whatever.

Reproducible: Always
Steps to Reproduce:
1. minimal install
2. ...
3. Profit!
Comment 1 Bill Nottingham 2004-10-15 16:03:26 EDT
Is your default runlevel runlevel 5?
Comment 2 Colin Walters 2004-10-15 16:12:32 EDT
I think so.  Not entirely sure though.  I've already installed X and
stuff now, so I can't check.
Comment 3 Jeremy Katz 2004-10-15 16:17:32 EDT
Was this via kickstart or a manual install?  Can you attach
/root/install.log and /var/log/anaconda.log?
Comment 4 Colin Walters 2004-10-15 16:22:38 EDT
Created attachment 105303 [details]
install log
Comment 5 Colin Walters 2004-10-15 16:23:17 EDT
Created attachment 105304 [details]
anaconda's slitherings
Comment 6 Colin Walters 2004-10-15 16:23:45 EDT
This was a manual install.
Comment 7 Jeremy Katz 2004-10-19 13:20:43 EDT
Hrmm, this just worked fine for me.  

What type of install did you select of workstation, desktop, server,
custom?
Comment 8 Colin Walters 2004-10-19 13:28:24 EDT
I think I actually selected the default (Desktop, right?), then went
on later, and found it needed 3 CDs, while I only had the first 2.  So
I kept trying to remove things to make it only require 2, but couldn't
find what was on CD 3 easily, so I just gave up and checked "minimal"
in the "configure packages" screen.
Comment 9 Jeremy Katz 2004-10-19 14:43:20 EDT
Aha, the going back is key.  Fixed in CVS
Comment 10 Colin Walters 2004-10-19 14:49:13 EDT
Cool, thanks, I'm glad you're able to get even these relatively minor
bugs :)

Note You need to log in before you can comment on or make changes to this bug.