Bug 1359909 - pods are named 'container groups' in the policy explorer right cell
Summary: pods are named 'container groups' in the policy explorer right cell
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.8.0
Assignee: Beni Paskin-Cherniavsky
QA Contact: Dmitry Misharov
URL:
Whiteboard: container:ui:control
: 1394797 (view as bug list)
Depends On: 1394797
Blocks: 1360772 1397248
TreeView+ depends on / blocked
 
Reported: 2016-07-25 17:43 UTC by Mooli Tayer
Modified: 2017-06-12 16:21 UTC (History)
12 users (show)

Fixed In Version: 5.8.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1360772 1397248 (view as bug list)
Environment:
Last Closed: 2017-06-12 16:21:50 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of the bug (126.24 KB, image/png)
2016-09-09 08:51 UTC, Dmitry Misharov
no flags Details

Description Mooli Tayer 2016-07-25 17:43:14 UTC
Description of problem:
The right part of the policy explorer screen shows "Container Group Compliance/Control Policies" instead of  "Pod Compliance/Control Policies"

Note the name on the accordion is correct 'Pod' so there is currently a mismatch.

Version-Release number of selected component (if applicable):



How reproducible:
100% if there are compliance policies towards pods

Comment 2 Mooli Tayer 2016-07-25 17:49:01 UTC
Chris we are interested in having this fix for 5.6.1

Comment 3 Beni Paskin-Cherniavsky 2016-07-25 22:42:44 UTC
It's a bit more complicated, let me take a step back.

"Container Group" didn't actually occur in Control Explorer in 5.6.0 because it didn't support pods.  But multiple strings in right sides and some toolbar buttons use non-translatable non-controllable entity names mechanically derived from class names.
It wasn't highly visible in English e.g. "Container Replicator" vs "Replicator" is not too bad, but now that 
https://bugzilla.redhat.com/show_bug.cgi?id=1346057
is landing, it will expose the more inconsistent "Container Group" vs "Pod".
In other locales, it's visibly causing untranslated terms.

Most of these happen both on darga and master,
so I believe this should remain a 5.7.0 BZ and get a Z-stream clone.

Examples (non-exhaustive):
https://cloud.githubusercontent.com/assets/273688/17083392/4b6f2ade-51a8-11e6-8292-b9860a696235.png (*)
https://cloud.githubusercontent.com/assets/6648365/16489785/4e76e76e-3ed7-11e6-9bed-89f7aae043a8.jpg
https://cloud.githubusercontent.com/assets/273688/16265415/e0787e62-3887-11e6-9d69-a8d5d695a022.png (untranslated "Host" in right side title).
https://cloud.githubusercontent.com/assets/3433754/17063911/9222692a-4fee-11e6-96b6-36a51def92d7.png (right title and button dropdown) 

(*) the first one was already made translatable on master by
https://github.com/ManageIQ/manageiq/pull/9543 
and thanks to this BZ already got backported to darga / 5.6.1:

  Darga backport details:

  commit 8b95ad166d37fdacd57d6c88b249bb1809f53cbf
  Author: Martin Povolny <mpovolny@redhat.com>
  Date:   Thu Jun 30 16:35:56 2016 +0200

    Merge pull request #9543 from mzazrivec/gettext_fixes_in_policy_foders_view

    Translatable policy folder names under Control -> Explorer -> Policies
    (cherry picked from commit b517fe5545c84d34c750fb48b229dbe8cf7de38f)

(*) at this moment this particular place turned into emtpy-strings bug,
fixed by https://github.com/ManageIQ/manageiq/pull/10013 (waiting for merge)

Several others can be fixed by
https://github.com/ManageIQ/manageiq/pull/9347

Comment 4 Beni Paskin-Cherniavsky 2016-08-08 11:07:51 UTC
Submitted
https://github.com/ManageIQ/manageiq/pull/9347

It now fixes all issues I'm aware of in the this BZ.
Awaiting review.

Comment 5 CFME Bot 2016-08-08 15:00:51 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/40d3263a82282c26854eac34791f2678265ce83a

commit 40d3263a82282c26854eac34791f2678265ce83a
Author:     Beni Cherniavsky-Paskin <cben@redhat.com>
AuthorDate: Mon Aug 8 16:19:15 2016 +0300
Commit:     Beni Cherniavsky-Paskin <cben@redhat.com>
CommitDate: Mon Aug 8 16:19:15 2016 +0300

    Fix multiple ui_lookup(:model => nonCamelized)
    
    Hopefully fixed all occurrences in MiqPolicyController.
    Enables some non-working translations, affects even English terminology
    ("Container Image -> Image" etc).
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1359909
    https://bugzilla.redhat.com/show_bug.cgi?id=1360772

 app/controllers/miq_policy_controller.rb | 32 ++++++++++++++++++++------------
 1 file changed, 20 insertions(+), 12 deletions(-)

Comment 6 Dmitry Misharov 2016-09-09 08:50:10 UTC
I can still reproduce the bug in 5.7.0.0.20160906172503_12f65cb. Create any container policy and after that you can see "Containerreplicator", "Containergroup", "Containernode" or "Containerimage" in the right cell.

Comment 7 Dmitry Misharov 2016-09-09 08:51:25 UTC
Created attachment 1199337 [details]
Screenshot of the bug

Comment 11 Beni Paskin-Cherniavsky 2016-10-25 12:25:06 UTC
Confirmed, still happens on master: right after policy creation the title is "Containernode".  If you navigate to same policy later, it's "Node".
Oh, yes, I once opened an issue for this case and forgot to fix it: https://github.com/ManageIQ/manageiq/issues/10500

Comment 12 Barak 2016-11-07 12:02:52 UTC
it is too late to fix for 5.7.0 as this is not a blocker.
Hence moving to cfme-future.

This is minor, Loic please target to the version you want it.

Comment 14 Dmitry Misharov 2016-11-16 07:18:09 UTC
*** Bug 1394797 has been marked as a duplicate of this bug. ***

Comment 16 CFME Bot 2016-11-21 18:21:16 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/2dd47b004f620fcdfd18283b9870d58a395fba97

commit 2dd47b004f620fcdfd18283b9870d58a395fba97
Author:     Beni Cherniavsky-Paskin <cben@redhat.com>
AuthorDate: Sun Nov 20 15:44:31 2016 +0200
Commit:     Beni Cherniavsky-Paskin <cben@redhat.com>
CommitDate: Sun Nov 20 15:44:31 2016 +0200

    Fix policy x_node after create/copy/delete
    
    In Control explorer, fixes "Containernode", "Containergroup" etc
    in right side titles to be "Node", "Pod" etc (or their translations)
    immediately after creating, copying or deleting a policy.
    
    Fixes #10500, which was the last known instance of
    https://bugzilla.redhat.com/show_bug.cgi?id=1359909
    
    Modified spec to use 2-word ContainerGroup instead of Host which does
    fail without this fix and works with it.

 app/controllers/miq_policy_controller/policies.rb       |  6 +++---
 spec/controllers/miq_policy_controller/policies_spec.rb | 16 ++++++++--------
 2 files changed, 11 insertions(+), 11 deletions(-)

Comment 17 Beni Paskin-Cherniavsky 2016-11-21 20:36:29 UTC
Steps to verify just the last fix:

- Create a new Pod (control or compliance) policy, verify right side title says "Pod".
- Configure -> Copy Policy, verify right side title says "Pod".
- Configure -> Delete Policy, verify right side title says "Pod".

Bonus points for doing this in non-english locale and verifying the
entity name (Pod in this example) is translated.

Comment 19 Beni Paskin-Cherniavsky 2016-11-22 22:29:10 UTC
And another manifestation: https://github.com/ManageIQ/manageiq/issues/10540
fixing...

Comment 20 Loic Avenel 2016-11-28 13:37:14 UTC
(In reply to Barak from comment #12)
> it is too late to fix for 5.7.0 as this is not a blocker.
> Hence moving to cfme-future.
> 
> This is minor, Loic please target to the version you want it.

Yes, we should fix it for Errrata.. not a blocker

Comment 22 Beni Paskin-Cherniavsky 2016-12-07 12:32:04 UTC
Moving to POST - the 2 recent fixes merged on master (not yet euwe):

https://github.com/ManageIQ/manageiq/pull/12760
https://github.com/ManageIQ/manageiq/pull/12802

Chris, Loic: you said "not a blocker" above, the 5.7 clone (bug #1397248) is now blocker+.
Is euwe still open for 5.7.0 blockers?  Can/should I label the PRs blocker to get them backported?

Comment 23 Federico Simoncelli 2016-12-07 13:04:32 UTC
(In reply to Beni Paskin-Cherniavsky from comment #22)
> Moving to POST - the 2 recent fixes merged on master (not yet euwe):
> 
> https://github.com/ManageIQ/manageiq/pull/12760
> https://github.com/ManageIQ/manageiq/pull/12802
> 
> Chris, Loic: you said "not a blocker" above, the 5.7 clone (bug #1397248) is
> now blocker+.

It's a blocker for 5.7.1 as the target release states.

Comment 24 Beni Paskin-Cherniavsky 2017-01-12 15:04:01 UTC
Note: more instances of "Containergroup" have been discovered: bug 1404463.

I arbitrarily decided to draw a line and keep that a new BZ instead of growing this one.  I think it's already too hard to figure out what to verify in this BZ...
PMs, QE: if do you prefer to grow this BZ, feel free to dup bug 1404463 to this.  Then this will have to move back to ASSIGNED.

Comment 25 Dmitry Misharov 2017-02-28 15:42:09 UTC
Verified in 5.8.0.2.20170223184827_489bf7c. Titles of the policies are correct in the right cell.


Note You need to log in before you can comment on or make changes to this bug.