Bug 136011 - hotplug firmware loading stopped working
Summary: hotplug firmware loading stopped working
Alias: None
Product: Fedora
Classification: Fedora
Component: udev
Version: 3
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
: 136052 (view as bug list)
Depends On:
Blocks: FC3Blocker
TreeView+ depends on / blocked
Reported: 2004-10-16 19:20 UTC by Jukka Ketelaars
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Clone Of:
Last Closed: 2004-10-19 08:40:51 UTC

Attachments (Terms of Use)

Description Jukka Ketelaars 2004-10-16 19:20:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012

Description of problem:
After running up2date today hotplug firmware loading for the ipw2100
stopped working. Neither during init, nor after the system has started
up does the firmware load succeed.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install ipw2100 driver (0.56)
2. boot system
3. modprobe ipw2100

Actual Results:  ipw2100: Intel(R) PRO/Wireless 2100 Network Driver, 0.56
ipw2100: Copyright(c) 2003-2004 Intel Corporation
ACPI: PCI interrupt 0000:02:02.0[A] -> GSI 5 (level, low) -> IRQ 5
ipw2100: 0000:02:02.0: Detected at mem: 0x90000000-0x90000FFF ->
e0ea4000, irq: 5
divert: allocating divert_blk for eth1
eth1: Using hotplug firmware load.
eth1: Firmware 'ipw2100-1.3.fw' not available or load failed.
eth1: ipw2100_get_firmware failed: -2
eth1: Failed to power on the adapter.
eth1: Failed to start the firmware.
divert: freeing divert_blk for eth1

Expected Results:  Firmware should have been loaded.

Additional info:

I have the firmware files at both the new (/lib/firmware) as the old
(/usr/lib/hotplug/firmware) locations. I have tried this with older
kernels and older versions of the ipw2100 and the same problem always
appears (note: these were also combinations that used to work).

The strange thing is that the current version of hotplug has been
installed on my system since 2004-10-6 and has worked fine, so I think
it may actually be another component that is interfering. 

The change must be very recent as the last time I ran a complete
up2date was 2004-10-14 and up to today it worked fine both during and
after init (today is 2004-10-16).

I have no idea as to how to attack this problem. If you have any
suggestions on how to analyze it, please let me know.

Comment 1 Bill Nottingham 2004-10-17 03:50:00 UTC
This is a udev bug.

Comment 2 Jukka Ketelaars 2004-10-17 07:12:02 UTC
I'm running udev-038-2

Comment 3 Trevor Smith 2004-10-17 23:59:39 UTC
I have the same error using the ipw2200 driver

output of 'modprobe ipw2200' to /var/log/messages:

Oct 17 20:00:34 odin kernel: ipw2200: Intel(R) PRO/Wireless 2200/2915
Network Dr iver, 0.11
Oct 17 20:00:34 odin kernel: ipw2200: Copyright(c) 2003-2004 Intel
Oct 17 20:00:34 odin kernel: ACPI: PCI interrupt 0000:02:03.0[A] ->
GSI 7 (level , low) -> IRQ 7
Oct 17 20:00:34 odin kernel: ipw2200: Detected Intel PRO/Wireless
2200BG Network  Connection
Oct 17 20:00:44 odin kernel: ipw2200: ipw2200_boot.fw load failed
Oct 17 20:00:44 odin kernel: ipw2200: Unable to load firmware: 0xFFFFFFFE
Oct 17 20:00:44 odin kernel: ipw2200: failed to register network device
Oct 17 20:00:44 odin kernel: ipw2200: probe of 0000:02:03.0 failed
with error -5
Oct 17 20:00:44 odin wait_for_sysfs[4102]: either wait_for_sysfs (udev
038) need s an update to handle the device
'/class/firmware/0000:02:03.0' properly (4) or the sysfs-support of
your device's driver needs to be fixed, please report to <l

Comment 4 Bill Nottingham 2004-10-18 03:04:13 UTC
*** Bug 136052 has been marked as a duplicate of this bug. ***

Comment 5 Harald Hoyer 2004-10-18 14:36:10 UTC
Please retry with udev-039

Comment 6 Joakim Arnling 2004-10-18 18:18:23 UTC
Had the same problem with the ipw2200-driver.
udev-039 works fine!

Comment 7 Jukka Ketelaars 2004-10-18 18:42:33 UTC
udev-039 also fixed this for ipw2100.

Note You need to log in before you can comment on or make changes to this bug.