Bug 136013 - [FHS] [read-only /usr] update-mime-database creates files not tracked by RPM in /usr/share/mime
[FHS] [read-only /usr] update-mime-database creates files not tracked by RPM ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: shared-mime-info (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
: 132847 (view as bug list)
Depends On:
Blocks: ReadOnlyFS
  Show dependency treegraph
 
Reported: 2004-10-16 15:53 EDT by Daniel Reed
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-17 05:25:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
list of all files in /usr/share/mime/ that are in neither rpmdb nor rpmdb-fedora (40.96 KB, text/plain)
2004-10-16 17:24 EDT, Daniel Reed
no flags Details

  None (edit)
Description Daniel Reed 2004-10-16 15:53:27 EDT
User-Agent:       
Build Identifier: 

After an installation of Fedora Core rawhide, a process ``update-mime-database''
modifies files in the path ``/usr/share/mime''.

``/usr/share/mime'' is owned by the package ``shared-mime-info''.
``update-mime-database'' is also owned by the package ``shared-mime-info''.


http://www.pathname.com/fhs/pub/fhs-2.3.html#THEUSRHIERARCHY

``/usr is the second major section of the filesystem. /usr is shareable,
read-only data. That means that /usr should be shareable between various
FHS-compliant hosts and must not be written to. Any information that is
host-specific or varies with time is stored elsewhere.''

http://www.pathname.com/fhs/pub/fhs-2.3.html#USRSHAREARCHITECTUREINDEPENDENTDATA

``The /usr/share hierarchy is for all read-only architecture independent data
files.''

http://www.pathname.com/fhs/pub/fhs-2.3.html#THEVARHIERARCHY

``/var is specified here in order to make it possible to mount /usr read-only.
Everything that once went into /usr that is written to during system operation
(as opposed to installation and software maintenance) must be in /var.''

http://www.pathname.com/fhs/pub/fhs-2.3.html#VARCACHEAPPLICATIONCACHEDATA

``/var/cache is intended for cached data from applications. Such data is locally
generated as a result of time-consuming I/O or calculation. The application must
be able to regenerate or restore the data. Unlike /var/spool, the cached files
can be deleted without data loss. The data must remain valid between invocations
of the application and rebooting the system.''

Reproducible: Always
Steps to Reproduce:
Comment 1 Daniel Reed 2004-10-16 17:24:00 EDT
Created attachment 105330 [details]
list of all files in /usr/share/mime/ that are in neither rpmdb nor rpmdb-fedora
Comment 2 Matthias Clasen 2006-11-26 12:20:38 EST
This is still the case. But I don't think the "readonly /usr" argument holds
much water, since you have to write to /usr at package installation time anyway,
so it does not seem unreasonable to update mime information at the same time.

I recommend moving this to upstream, and see if anybody cares enough about this
to do something about it.
Comment 3 Bastien Nocera 2007-02-01 11:22:06 EST
*** Bug 132847 has been marked as a duplicate of this bug. ***
Comment 4 Bastien Nocera 2007-04-17 05:25:46 EDT
The upstream being at https://bugs.freedesktop.org/index.cgi

Note You need to log in before you can comment on or make changes to this bug.